Plasma issue since 5.26 : Hot corners


(Plasma running on X11, not Wayland as Wayland performances are crappy)

With Plasma 5.25 on a Pinebook Pro, the hot corners worked perfectly : pushing the mouse cursor to the upper left corner would display a presentation of all the windows from all the desktops.

Since Plasma 5.26 this is broken : When the mouse cursor is pushed against the corner, the corner turns blue (which means the hot corner is supposed to be activated) but nothing further happens.

If I go to Plasma configuration and disable it, the re-enable it, it works correctly ONE TIME immediately after, but one time only.

Has anybody else noticed this, or could confirm it on another machine ?

yep, one time only/Pi4b.

I have mine set for Overview bottom left, and show Kwin bottom right. I have the Activation delays set to as low as they will go. I noticed a good while back that Present Windows - All Desktops would not work all the time. so I went in and change the default Activation Delay and Reactivation Delay to as low as the can go and haven’t noticed a issue since.

Not the same behaviour observed here. Anytime I change the settings to whatever, it works once, but only once.

I have had any issues, however, after a Plasma update I always reset the cache with
rm ~/.cache/*plasma* ; killall plasmashell && kstart5 plasmashell

This may have helped. :man_shrugging:

Thanks for the hint about purging the plasma cache, but it didn’t help.

I’ve noticed that the issue is present only on and X11 Plasma session, the feature works well in a Wayland session, so I believe it’s a clear Plasma bug and will report it upstream.

Wayland Plasma tend not to play nice together whereas X11 and Plasma generally don’t have issues together.

No issues with hot corners here (Plasma 5.26 running on X11).

I also just tried, and no issues here. Plasma 5.26.2, X11.

Since you tried clearing the cache to no avail, you might have corrupted config files? May I suggest you also try removing (of course back them up first if you wish) the config files and log out and in again (new configs will be generated).

Another option is that you could try making a new user account and try it there.

Nope, I don’t think I have corrupt config files, and I get the problem both on a Pinebook Pro and on a Raspberry Pi 4, I would be suprised to have corrupt config files on both machines - and nothing else could make me think that my config files are corrupt…

Plus it works in Wayland but not on X11.

Might want to look for or file a bug report:

Already done. I had the suggestion to try Plasma 5.26.2, that might have bugfixes pertinent to this issue.
So I’m waiting for 5.26.2 to land into Manjaro ARM testing…

5.26.2/wayland didn’t fix this issue.