Plasma Firewall blocks KDE Connect from connecting and the device being shown in the mobile app

As discovered previously with the help of Fabby, that after last update plasma-firewall started blocking my KDE Connect from connecting and the PC being discoverable.

How do I make my KDE Connect work properly again?

Best regards,

Unlock ports 1714-1764.

I am a novice. Can you please explain in more detail what would need to do?

Based on

My outputs:

sudo netstat -tunelp | grep -i kdeconnect
tcp6       0      0 :::1716                 :::*                    LISTEN      1000       25622      1035/kdeconnectd    
udp6       0      0 :::1716                 :::*                                1000       25621      1035/kdeconnec
netcat -z -v 1714-1764
latitux.local [] 1716 (xmsg) open

KDE Connect listens to 1716 and it seems to be open.

Is it or is it not?

  1. If it is, what Tomek is trying to tell you is:

    open all ports from 1714 up to and including 1764.

  2. If it is not or you don’t know, please read the documentation of plasma-firewall as neither of us is running that, so we cannot tell you what to do exactly; we can just point you in the right direction…


You can do it via GUI, just go to system settings or via terminal - exact command depends on what firewall backend you use, ufw or firewald.

Via GUI it seems I need to do it manually. All the 50 ports one by one. That’s why I tried to identify which port KDE Connect uses. But yeah - it seems not enough to verify that 1716 is open.

Along the way I tried to see if I find the docs for plasma-firewall. Only managed to find the git-hub page for the package and some generic KDE pages. Probs my google-fu on duckduck go needs to be a bit better.

I’ll try again a more focused (as in ‘less narrowing’ probably) search, when I can.


In KDE Docs didn’t manage to find anything on plasma-firewall.

My backend is ufw. "OP on opening port ranges in ufw" (

sudo ufw allow 1716:1764/udp

That command solved the issue.

Thanks guys!!

Only strange thing is that plasma-firewall doesn’t let to add port ranges in the rule creation dialog.

It shows the rule as an image but doesn’t let type : in the port field. Might be that it just shows what backend tells it.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.