Plasma Envirement keeps crashing

My Plasma envirement now keeps crashing on startup since I attempted to use the Plasma Customization Saver to load a desktop. I can still use apps like Yakuake which I believe is the only way I can still navigate my computer, but the only desktop thing that works other then apps is tiling. Is their any way to fix this?

Sometimes customizations renders the desktop less useful - sometimes even inoperable.

There can be any number of reasons and they can be extremely hard to find for an outsider to your system - after all you are the only one knowning what customization, changes and applications you have applied.

I have sometimes had an issue I couldn’t pinpoint so my approach in such case

  • to logoff
  • switch to TTY5
  • login as my user
  • move all kde-related configs from ~/.config to a temporary location
  • switch back to TTY1
  • login and let Plasma populate the defaults

Using a terminal filemanager like Midnight Commander (mc package) is invaluable in such case.

1 Like

I do not know why, but for some reason my locks creed won’t let me switch to a different type of session on my lock screen.

can you open system settings and reset the theme to defaults?

I have tried that and the only thing that changed was the window borders on applications.

and can you enter into TTY ctrl+alt+f2 - if f2 doesnt work try f1-f6 keys?

TTY5 CtrlAltF5
TTY1 CtrlAltF1

This appeared to of worked but I am still very new to the terminal.

Installl a terminal file manager - it makes the tty much less intimidating.

sudo pacman -Syu mc

Then run it


A guide to the basics of Midnight Commander (skip the install part - use above to install)

so try these commands:
rm -rf ~/.cache/*
rm ~/.config/Trolltech.conf
kbuildsycoca5 --noincremental
then reboot, if it doesnt work, we try to reset your plasma

This reset appeared to have worked, thank you.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.