Plasma Desktop displayed in XMonad

I am trying to get xmonad to work as my window manager. I have the KDE installed, and I don’t want to lose some KDE functionality (mainly the theme of the windows and the cursor). So I have this xmonad.sessions file:

[Desktop Entry]
Comment=Lightweight X11 tiled window manager written in Haskell
Exec=env KDEWM=/home/yecinem/.cabal/bin/xmonad /usr/bin/startplasma-x11

which starts xmonad with the correct cursor theme and everything. The problem is that right after xmonad starts, the plasma desktop appears and covers xmobar and the background, which is pretty annoying.

Any help is appreciated!


You are starting two Window Managers simultaneously the way you do it now.
Better let Plasma know that and use only xnomad then.
Edit/create ~/.config/plasma-workspace/env/ file and add:
export KDEWM=/home/yecinem/.cabal/bin/xmonad

And depending how you set the compositor then you might need too this line:
xcompmgr -C

Hope this helps you go on the right track.


Thank you for your response! I’m afraid that isn’t changing anything. The environment variable KDEWM gets correctly set through the xmonad.sessions file. I followed your instructions and nothing changed…

I had to disable plasmashell!
I managed to solve this by following the Arch wiki (I can’t put links in my post, just google “xmonad arch wiki”, it’s in 5.10.1)
The file /etc/xdg/autostart/plasmashell.desktop had a different name in my system (org.kde.plasmashell.desktop) the rest is the same.

Thank you!

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.