Plasma 6 Wayland

Hi, I installed Manjaro 24.0 KDE minimal, featuring Plasma 6, and while the X11 session works, the wayland session ends in a black screen.

I use nvidia 550 and modesetting is already enabled by default, apparently.

Thank you in advance.

I dont know what information/logs I should provide, fell free to ask any questions.

Have you tried adding the modules to kernel cmd line?

I just installed the drivers using the default manjaro driver manager, and I confirm they are working. How to add the modules to the cmd line?

Please see → Kernel mode setting - ArchWiki

Alright, it is apparently solved by adding options nvidia_drm fbdev=1 to /etc/modprobe.d/my-wayland.conf, in addition to modeset=1 which was already in /etc/modprobe.d/mhwd-gpu.conf (this is generated by mhwd, thats why I did not add the option there). More info here.

However, if this is required for wayland, it should already be enabled by default (?).

Thanks for the help.

I just want to verify - for forum reasons - that you have nvidia and are using plasma 6 with wayland.

And it isnt a disaster after adding those options?

You arent having seizure-inducing flashing etc?

If they are good defaults for nvidia in general then they should likewise be in the configs provided by the nvidia mhwd profile.

Yes, I have an GT 1030 card and I only have flickering with certain X11 apps (e.g. discord). This is to be expected since explicit sync did not land yet, I assume.

Other than that, it is working well. It seems to be the only way to run wayland in this pc (your mileage may vary). Otherwise, I just get a black screen. This do not necessarily mean they are good defaults, please dont cite me on this. I could get wayland working on the same system in EndeavourOS without this tweak (I dont know if it is already done by default).

PS: probably not related, but I sometimes I cant logout back to sddm, also getting stuck to a black screen with a mouse.

I only asked because one of the reasons for the long delay of plasma 6 on manjaro stable was the fear of the new wayland default. The cited justification for it was the idea that nvidia+wayland can/would produce flickering to an extent that could be seizure-inducing. So plasma-workspace was patched to default to X11.

As far as I know, flickering only happens for XWayland apps on Nvidia+Wayland (they are very annoying though), and it should be solved soon with the release of nvidia 555 driver (hopefully).

I think Manjaro defaulting to X11 was a good choice, especially for new users who never used linux. Experienced users can always switch if they want.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.