Plasma 6 not showing selected menu entries

Hey all, I’ve raised this in the testing announcement but hopefully I’ll get some help here or some other people may be facing the same issue.

I was using NVidia on wayland on plasma 5 for a few weeks hoping to get the transition to 6 smooth. Everything is working perfectly fine with the exception of a few visual issues:

The selected app doesn’t show up in the bottom panel, “start menu” doesn’t show what’s selected, same for krunner, there’s no slider on the volume, this among a lot of other visual things that are just not showing.

I’ve tried creating a brand new user, applying different themes/appearances but I had no luck so far.

I was hoping there’s a way to restart from default the configs on plasma or something so I can try to fix this without having to format the PC and install everything again from scratch. I’m happy to try other options as well if anyone has any idea what this issue can be.

Are you using a third party widget?

Same for theme … especially icon theme, as thats whats used now not what your plasma style provides. And if you are … have you updated or rebuilt it?
(papirus icons just had a new release and should work well, ex, wifi is no longer a network folder icon)

There sorta is … as far as your desktop configuration is concerned.

cd ~/.config
for j in plasma*; do mv -- "$j" "${j%}.bak"; done
mv Trolltech.conf Trolltech.conf.bak
rm -rf ~/.cache/*
kbuildsycoca6 --noincremental

Do note this will reset most all desktop settings.


I am not sure if I’m using a third party widget I would expect I’m not, I usually don’t customise these things.

I am usually going to the Global Theme and applying the theme for everything with no luck, I tried all the ones that come with Manjaro but no luck, then I tried this apple one and it actually fixed things, the only place where I’m missing the border in an input now is the login screen.

Here’s how it’s looking now:

Is it possible that there’s something wrong with these default themes or something? Is there an easy way to force a reinstall on them maybe? I don’t mind the apple one but I am kind of used to the Breeze/Breath icons so I’d much prefer to just stick to them.

One thing I noticed is if I apply the Apple theme, then apply another of the themes I have available, the start menu stays the apple way and when I restart I go back to the broken start menu. Not sure if this info helps.

Yes, besides breeze.

Please use the reset steps like above.

Of course you should also be fully up to date. So just to be sure;

sudo pacman -Syu

I’ll try the config one later as I’ll write down all my changed configs first, just for the sake of information I have the system updated and I tried the following:

sudo pacman -S breeze-icons breeze-gtk breeze plasma6-themes-breath plasma6-themes-breath-migration plasma6-themes-breath-extra sddm-breath-theme

All these were already installed so it just reinstalled things, restarted, applied the themes but still broken, so I re-applied the apple one with no icons, it’s still oddly coloured to me as I was expecting green instead of blue on the volume slider and whatnot but at least the icons are looking like what I am used to.

The only left over issues with the theme solution are the mouse cursor still not respecting night light and there’s no border on the input box on the login screen. But that’s likely just related to the broken themes I seem to have.

I’ll try the full reset later today and get back here to report, thanks for all the help so far :slight_smile:

Is not an update though.

PS. Usually this wouldnt have much affect on things like theming, but you never know…
Might as well check your pacnews too;

pacdiff -o