Plasma 6.0.4 Root privileges are randomly refused

Operating System: Manjaro Linux 
KDE Plasma Version: 6.0.4
KDE Frameworks Version: 6.1.0
Qt Version: 6.7.0
Kernel Version: 6.8.7-1-MANJARO (64-bit)
Graphics Platform: Wayland

After upgrading to Plasma 6.0.4, root privileges are refused in Kate, Dolphin Open as Administrator, Partition Manager, GNOME Disks…, this happens randomly, it always works after fresh login then it stops accepting root privileges after certain time.

My user is already part of wheel group.

It seems root privileges are refused only via this prompt:

While entering root via this prompt works fine (e.g KsystemLog)

And entering root password via terminal works fine.

I tried to run /usr/lib/polkit-kde-authentication-agent-1 via konsole, and tried to enter my root password in Kate, it seems there’s crash:

New PolkitAgentListener  0x5b25c81774f0
Adding new listener  PolkitQt1::Agent::Listener(0x5b25c8176e30) for  0x5b25c81774f0
Listener online
Authentication agent result: true
Listener adapter polkit_qt_listener_initiate_authentication
GSimpleAsyncResult: 0x5b25c8223370
polkit_qt_listener_initiate_authentication callback for  0x5b25c81774f0
Initiating authentication
Action description has been found
User:  "unix-user:med"
User:  "unix-user:mohamed"
Trying again
Request:  "Password: "
qrc:/qt/qml/org/kde/desktop/private/TextFieldContextMenu.qml:235:5: QML MenuItem: Binding loop detected for property "implicitWidth"
Dialog accepted
Completed:  true
Finishing obtaining privileges
Listener adapter polkit_qt_listener_initiate_authentication_finish
polkit_qt_listener_initiate_authentication_finish callback for  0x5b25c81774f0
Finish obtain authorization: true
Dialog cancelled
Finishing obtaining privileges
KCrash: appFilePath points to nullptr!
KCrash: Application '<unknown>' crashing... crashRecursionCounter = 2
zsh: segmentation fault  /usr/lib/polkit-kde-authentication-agent-1

Seems it’s a confirmed bug

Confirm downgrading qt6-base to 6.7.0beta3 is a temporary fix for now.


What is this?

You just … open with kate and save.

1 Like

This open Dolphin as root, and you can perform any file/folder operation as root.

While saving and entering root password, it fails to gain root privileges.

But you dont need that.
Just open it in kate from regular dophin in regular kate and hit save and it will ask you for permissions.

Yes, and when it asks for permissions, and I enter my root password, it fails. See my updated post above for more info. :slight_smile:

Then I cannot reproduce :person_shrugging:


It also works for me after a fresh login, but after a certain time of usage, something breaks it, and I’m not sure which process/operation is the culprit.

I had wondered about something like sudo lockout - which can occur after multiple failed password attempts. But you said regular sudo works, so its at least not exactly that. I also know those polkit prompts seem to fail out after a relatively short amount of time with no input. But in my case they will happily work (prompt/save) again if I open the file and try again.

I tried closing all affected apps and do something else then repeating the test, but it fails with that specif prompt. Maybe the backend behind it is blocked or stuck at something.

Why would you enter root password? You enter your own password.


Oh jeez, I think that may have been the issue. :face_exhaling:

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.