Plasma 5.24.0 is buggy in my heavy modified and personalized desktop

This release is again a problematic one.

  1. Various issues with latte and its applets - recompiling didn’t work. To say it short: latte-dock-git crashes, need recompilation, buttons don’t display proper icons, appmenus from latte have display problems
  2. Once again, regression with startup sound that doesn’t play.
  3. New overview effect is still old overview.
  4. Cover and flip window switch effects are back but seem to be buggy - at first, for a long time they weren’t showing preview of all windows. After an hour, all came back.
  5. On Wayland it’s not unicorn and rainbows, still plenty of bugs on nvidia that are immediately in your face (gtk apps are still ugly - the old bug that is not fixed).

Basically, kwin and effects are behaving randomly and unpredictable.

This probably is because I have a heavy modified and personalized desktop (installed and set 7 years ago), so someone with more vanilla setting won’t have such issues.

If you don’t want troubles, stay away from this update. If you want to help, test and submit bugs, this is the update for you ;). I submitted bugs I discovered, but their random nature makes it hard to determine what the bug is really about.

Previews Plasma versions were uneventful, this one is… “interesting” to put it mildly.


Bright side is, will have a bug release next Tuesday, and then another the Tuesday after that… So Hopefully will fix it.

1 Like

Can’t reproduce here.

Could you show me what’s wrong with them?

For me on wayland the windows are not remembering their places which makes me crazy!
It was working before this release.

It only works on my regular user. On test, vanilla user, the new overview is applied. This means, the cause is in the configs. However, I already tried to disable kwin, plasma, kde, various related configs - nothing helped. I deleted cache - still nothing. At the moment, I just can’t get the new overview.

It would be good to find the config and send it to KDE, so they would figure out why it overwrites the new effect. I already submitted a bug for it.

On the other hand, when I tried the new overview, I was a bit disappointed. There are no settings (like in the old one) and the focus immediately jumps to search box, which causes any shortcuts to not work, because they are recognized as a normal text within search box. So I can’t just jump in with my shortcut to new overview and close it with the same shortcut. For many it will be probably a non issue, because overview is a mean to choose a window or do some window/workspace manipulation, which usually closes the effect as well. However, there should be settings for this. At the moment, we get more complicated effect with fewer settings.

Sure. There are two problems here:

  1. The gtk theme is not applied on wayland, it just defaults to adwaita
  2. font rendering is pixelated

See here how it looks normally in Xorg session:

And this is how it looks on Wayland since many months:

Or maybe this is a bug only on my system? Is there someone with Nvidia to check this? Or maybe this is because of a chosen font? Possibly with some default font, the pixel effect is not shown? I remember reading about some font issues that could be it.

Remove GTK_USE_PORTAL=1. This envvar causes the bug.

1 Like

Where? In .xprofile I have only this:

[[ -f ~/.extend.xprofile ]] && . ~/.extend.xprofile
#export SAL_USE_VCLPLUGIN=gtk3_kde5
#export GTK_MODULES=appmenu-gtk-module

And here is my .profile:

[[ "$XDG_CURRENT_DESKTOP" == "KDE" ]] || export QT_QPA_PLATFORMTHEME="qt5ct"

[[ -f ~/.extend.profile ]] && . ~/.extend.profile
export MANGOHUD=1

EDIT: Found this and probably that is the explanation and solution:

However, I’m not sure how to change gsettings from reading this quickly. I guess I need to spend more time trying to understand it. It’s a bit frustrating that it’s not a few seconds solution where I just look and know what to do instantly.

Unfortunately, this wasn’t the solution. I installed dconf-editor and all settings are correct and changed by Plasma accordingly (proper themes and other settings). At this moment I have no idea why this is the way it is and how to fix it :frowning: .

Could you please check what the mentioned above envvar is set to?

Correct me if I’m wrong but to do that, from a terminal type echo $GTK_USE_PORTAL and see the result.

1 Like


So where do I change it?

First check if it is present in /etc/environment or not. If yes then remove it and logout and log back in. If not then do unset GTK_USE_PORTAL. Verify if changes took place or not with echo $GTK_USE_PORTAL. Output should blank/nothing.

Thanks. I did some tests and this didn’t solve this weird look on wayland, but first things first:

  1. In /etc/environment I have only:

So I used command unset GTK_USE_PORTAL and as you said, got blank response with echo. Rebooted, checked wayland - nothing’s changed.

  1. I found on Arch wiki this:

Qt apps run on GNOME Wayland have a non-matching window decoration look, even after setting a Qt theme

In order to have a matching window decoration look, you have to install qgnomeplatformAUR, and set the following environment variable: QT_QPA_PLATFORMTHEME='gnome' This fix is guaranteed to work with Adwaita or Adwaita-dark.

So I did just that and the result was that: a) wayland didn’t start at all, SDDM hang indefenitelly, b) on X11 my set icons were replaces with Breeze ones, only in some places, in others not, aurorae theme looked weird and basically it did something that affected and broke the look of the whole system. So I just reverted the changes. Rebooted, all went back to normal and I’m still not closer to solve this problem.

EDIT: I just realized, the solution from above is for Gnome, not Plasma… :man_facepalming: No wonder it didn’t work.

The GTK issue on wayland is also present on my test, vanilla user, so it’s not a config issue, or at least not a user config issue.

Is this problem existing only on my system, or do you have it as well? I don’t believe, it’s graphical drivers related, this wouldn’t make any sense. So what gives?

Or maybe forget it. Either I submit a bug or start a new, dedicated topic for that.

It might be a dumb suggestion from my side, but reapplying the following setting in the wayland session does not change anything, is it? You probably have done so already.

@michaldybczak I am able to replicate the issue on 5.24 wayland. Will get back if I reach somewhere.

Edit - As suggested by @raguse reapplying gtk settings fixes the issue in pamac.


Plasma 5.24 is not on Testing branch according to announcement threads and Branch Compare website.

Yes I know. That is from the kde-unstable repo. This doesn’t make a huge difference as the same happens with 5.24 from unstable branch.

If you have no idea where that variable is set … you could search of course.


grep -r "GTK_USE_PORTAL" / 2>/dev/null

(note the end is just to suppress warnings and the operation could take a while to finish … or rather hit Ctrl+C when you see the file)

1 Like

Yes, I have this problem when GTK_USE_PORTAL is set.

Try /etc/profile.d first, it might spare you the full disk search.