Pipewire won't let uninstalling itself

Hello, today I tried manjaro-pipewire, however it wasn’t good experience, my microphone wasn’t detected, if it was the sample rate was incorrect etc.
So I tried going back to pulseaudio which worked but when trying to remove last pipewire package “pipewire” I get following error:
removing pipewire breaks dependency 'pipewire' required by mutter
Is there a way to force remove it?

There is plenty of topics how to switch between the two and it’s not by removing pipewire package.

Edit: Manjaro has two meta packages and that’s all you need to switch: manjaro-pulse or manjaro-pipewire.

Hello

I also tried to do pipewire the other day and found that I couldn’t as my Jack or PEffects used something called Dbus to boot with, so I could not remove the dependencies without breaking a whole load of stuff.

I found this in these forums


ChrisCanyon

Basically, what you need to do is :

Remove every single package beginning with “pulseaudio”, then install manjaro-pipewire.
I did that recently on a fresh installation, that’s it.

Regarding Jack2 issue, here is below what @philm wrote on the Announcement section :

Pipewire tend to replace all stuff related to Audio. This time jack2 seems to create issues. In the past pipewire-jack provided jack2. However, since the lack of dbus support that line got removed and only conflicts kept. So if you use jack2 with the dbus feature, you may want to remove the pipewire-jack package. If not you can continue and additionally install lib32-pipewire-jack package.

Personally, when i installed manjaro-pipewire after uninstalled all pulseaudio* stuff, jack2 was not replaced by pipewire-jack, and it’s fine for my needs.


From what I can tell tho … Pipewire is not totally ready and still has a lot of bugs present & everyone ive chatted with has told me to go back and use PEffects … Even tho its unsupported :roll_eyes:

Hope it helps

Just found this 4 year ongoing support topic too

And this

Jackdbus support within Pipewire (#819) · Issues · PipeWire / pipewire · GitLab ( this is a very good read )

DO NOT DO THAT.

Installing manjaro-pipewire will take care of all conflicting packages

1 Like

installing manjaro-pulse didnt let me uninstall pipewire

It did switch your system to using pulseaudio though. You want to remove something that was “always” there.

Package pipewire cannot be removed on some DEs as it is required for wayland support

But PipeWire systemd socket and service can be disabled to use PulseAudio

systemctl --user disable --now pipewire.socket pipewire.service
1 Like

Where did I say that?

You can click the up arrow on the quote to see your original comment.

I inserted a link from this forum to a possible fix - Slightly different :roll_eyes:

Yes its a old thread, but it hadnt been placed in the “archived.forum.manjaro.org” area so it could have still been applicable?

there is a solution here

No, you don’t need to remove those packages first. Installing manjaro-pulse or manjaro-pipewire will take care of conflicting packages.

and it never will, this is another previous broken and closed forum, nothing to do with this one.

You wrote that, it is not the link you posted, it is your own message. Just for the sake of truth.

1 Like

Im sorry, but no …

The part that you insist I wrote

"Basically, what you need to do is :

Remove every single package beginning with “pulseaudio”, then install manjaro-pipewire.
I did that recently on a fresh installation, that’s it."

Is actually a response from " ChrisCanyon" on the thread that I linked…If you click on it you can see this :roll_eyes:

Just for the sake of truth … u kno :wink:

I mean that’s what you wrote in your post, in your reply, which basically means that is what you suggest people to do. That is how it works. Even if it is something you copied from elsewhere anyway, it is still your reply. It is actually even worse because what you copied and inserted into your message, is out of context and misleading, the reply was about its previous post.

1 Like

Everything you are saying in context to this thread is true, however please try to keep in mind that I was only trying to help.

The response that Ben gave singled me out rather than just advising not to do what the linked (supposed fix from my perceptive) was advising … Hence feeling a little attacked from trying to do something to help :neutral_face:

I have no doubt that a lot of people suggest things that are the wrong thing to do quite a bit, but I`d rather see the suggestions than scare people from even trying to present them in the 1st place … Blunt after comments like that with no thought as to why I may have posted it (to help) … dont help :neutral_face:

Being honest … Atm Im finding this forum a little frosty/cold, which is a shame. I am getting more help from forums that have nothing to do with the Os that Im having issues with, which is utterly bumming.

It seems that its an utter sin to disagree with anyone on here even if sometimes other forums are saying (and proving sometimes) the total opposite in regard to fixes?

Trying to get help on here is like trying to get a atom out of the blood you are trying to get out of the stone n offering your help just gets you jumped on if you say anything slightly wrong… Ahhh life :roll_eyes:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.