Pipewire samplerate

hey,

i have an issue, where can i change the sample rate for pipewire, i cant found the configs,

nothing in:

tree /etc/pipewire                                                                                                                                                                                                                                                            
/etc/pipewire
├── client.conf.d
├── client-rt.conf.d
├── minimal.conf.d
├── pipewire.conf.d
└── pipewire-pulse.conf.d

and in the home folder under the .config is no pipewire entry

any idea where i can find the configs or is there ab better solution to change the sample rate for an: BEHRINGER International GmbH UMC204HD 192k

its connected via USB

Maybe here?

https://wiki.archlinux.org/title/PipeWire#Changing_the_default_sample_rate

thx i copyed the config from /user/share/pipewire/pipewire.conf > ~/.config/pipewire/pipewire.conf and set the entrys to:

default.clock.rate          = 192000
default.clock.allowed-rates = [ 48000, 88200, 96000, 176400, 192000 ]

now i check how i can get it automatic to 192000 when the device can it

In the link @mithrial posted it says: ’ with configuration above, no resampling is done when supported.’ so

default.clock.allowed-rates = [ 192000 ]

should force resampling of everything below 192k.

Just a warning. Unless you have a pretty decent cpu/machine these settings may stress your pc, ramp up temps and fan noise whilst getting you no benefits at all.

Create .config/pipewire/pipewire.conf.d/clock-rate.conf

with

context.properties = {
    default.clock.allowed-rates = [ 48000 44100 88200 96000 192000 ]
    }

thats all

with your config everything is resample to 192khz

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.