Pipewire-jack vs jack2 - Standardlösung klappt nicht

Hallo!

Beim heutigen System-Upgrade konnte das Paket pipewire-jack nicht installiert werden, da es in Konflikt mit jack2 steht. (Habe dieses eine Paket abgewählt und alles andere aktualisiert)

Habe natürlich mitbekommen, dass dieses Problem vielfach aufgetreten ist und die Lösung pacman -S pipewire-jack sein soll.

Dies funktioniert bei mir jedoch leider nicht. Jack2 kann einfach nicht deinstalliert werden, weil das halbe System davon abhängt.
Da man liest, dass man es vor dem Upgrade machen soll, habe ich mit Timeshift zurückgerollt und versucht dann den Befehl auszuführen. Hilft leider auch nicht. Jack2 kann ich nun mal nicht loswerden.

Habe nun wieder alles andere upgegradet.

Wie kann ich nun pipewire-jack upgraden? Pipewire möchte ich nicht deinstallieren, da erst seit Pipewire mein Sound auch mit neueren Kerneln einigermaßen gut läuft.

Danke im Voraus!
Gruß

sudo pacman -S pipewire-jack

To remove Jack2, it will prompt.
Then

sudo pacman -Syu

to complete the update

Sorry I don’t speak German

The original pro-audio discussion:
https://lists.archlinux.org/pipermail/arch-proaudio/2022-January/000372.html

Hallo @Elektrotechniker,

bei mir hat ‘sudo pacman -S pipewire-jack’ auch nicht geholfen bzw lies sich nicht durchführen. Ich habe dann erstmal versucht ‘jack2’ einzeln zu deinstallieren, was auch nicht wegen der Abhängungkeiten funktionierte.

Ich habe dann die Abhängigkeiten von ‘jack2’ einzeln deinstalliert. Und danach lies sich auch 'jack2’ deinstallieren und 'pipewire' updaten.

Bei mir waren das die folgenden Pakete:

lib32-jack2 (1.9.20-3)
lib32-portaudio (1:19.7.0-1)
lib32-fluidsynth (2.2.5-1) 

Versuch mal ‘pamac remove jack2’ und schau dir an welches Paket da als Abhängingkeit meckert. Dann die meckernden Abhängigkeiten zuerst stückweise deinstallieren. Es sollten dann auch nicht so viele mehr sein. :grinning:

Wie - im Updatethread gepostet - half mir


sudo pacman -Sdd pipewire-jack

Danke, das hat mein Problem gelöst!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.