Pipewire/easyeffects sound stops on screen lock, unlocking changes output sink/input source

I am currently running pipewire 0.3.49 and easyeffects 6.2.4 on my manjaro xfce system with a rather special problem. Usually my external audio interface is selected as standard input source and output sink in pavucontrol. I’m using easyeffects solely to grab the audio input, filtering and noise cancelling it and feeding it into my chat applications.
When locking my screen, sound output is stopped. After unlocking my input source and output sink changed from the standard sound interface to the easyeffects source/sink. Therefore, I always have to change them back to the external interface.

So how can I stop pipewire from stopping the sound output when locking my screen and how to stop it from changing the standard sink/source when unlocking?

Steps I already tried:

  • changing to another sound interface → no change
  • exchange pipewire media-session manager for wireplumber → no change
  • activating my onboard audio: after unlocking it sometimes changes to the onboard audio → different result

Any ideas?

Currently running services:

systemctl --user list-unit-files | grep pipewire

pipewire-media-session.service                                                enabled   enabled
pipewire-pulse.service                                                        enabled   enabled
pipewire-session-manager.service                                              bad       enabled
pipewire.service                                                              enabled   enabled
pipewire-pulse.socket                                                         enabled   enabled
pipewire.socket                                                               enabled   enabled

As a simple smoke test, do you have pulseaudio also running? It might be left over from a previous updat.
Also, you could try wireplumber instead of pipewire-media-session.

pamac install wireplumber should be enough.

However, it might be something completely unrelated.

Hi, thank you for the hint.

I purged pulseaudio completely, it is not running nor installed. As you said, I purged pipewire-media-session and installed wireplumber. After verifying wireplumber is the only session manager running, I retried everything but the issue is still the same :frowning:

Yeah, well, sometimes it’s the easy things. Here not, I’m afraid I can’t help any further.

Well, after further investigation it seems to be in conjunction with light-saver as lock-screen manager. I replaced it with xfce4-screensaver and the issue seems to be gone.
So there seems to be trouble when light-locker presumably kills/suspends pipewire?