Pipewire auto switch headphones (not bluetooth)

On plasma 6.0 and 6.1 when I plug in headphones the sound does not automatically switch to the headphone output, for a while it worked for me:

pactl load-module module-switch-on-connect

but it stopped working too…

Yes. I also have this problem. I have been meaning to open a bud report but haven’t yet. I’m surprised this hasn’t been noticed by more users including KDE developers. Since I haven’t seen anyone else mention it. I figured it was something wrong with my setup.

I forgot to mention, it automatically switches when I unplug the headphones.

Update: I no longer have this problem - must have been fixed with one of the updates. This is what’s currently installed:

Pipewire: 1:1.2.0-2
Wireplumber: 0.5.5-1
KDE Plasma Version: 6.1.1
KDE Frameworks Version: 6.3.0
Qt Version: 6.7.2
Kernel Version: 6.9.7-1-MANJARO (64-bit)

I tried creating a user with a clean install (user directory) and it works.

I then deleted (after backup) the .config and .local files and directories, which had *pulse* and *pipewire* type names but it didn’t work.

Does anyone know how to completely delete the sound configuration in plasma 6?

is very annoying

The problem is solved if the first output is selected in the configuration, the name is not relevant, it is the first or the default output.

1 Like

thanks !