Pipewire and bluetooth linein

Im a first time user of Manjaro coming from windows and I could not find a good solution to what I am attempting to achieve. I own a goxlr audio interface and on windows I had linein setup to allow for output to go to my headphones and I am trying to achieve the same. I went ahead and already installed pipewire and ensured my headset works but I am not sure how to achieve audio outputting to my headset and controlling the volume with my goxlr. Hopefully someone has some experience or can point me in the right direction.

TC Helicon GoXLR mini
SteelSeries Arctic 7

Troubleshooting so far:
To install pipewire i did the following

pamac install manjaro-pipewire

sudo pacman -S easyeffects

When i run pamac list -i | grep pipewire i get the following output

gst-plugin-pipewire 1:0.3.73-1 extra 126.2 kB kpipewire 5.27.6-1 extra 293.5 kB libpipewire 1:0.3.73-1 extra 1.7 MB manjaro-pipewire 20221015-2 extra 1.6 kB pipewire 1:0.3.73-1 extra 3.3 MB pipewire-alsa 1:0.3.73-1 extra 1.2 kB pipewire-audio 1:0.3.73-1 extra 4.6 MB pipewire-pulse 1:0.3.73-1 extra 475.4 kB

Once I run pw-cli i get the following error

Welcome to PipeWire version 0.3.73. Type 'help' for usage. remote 0 is named 'pipewire-0' Error: "unsupported type PipeWire:Interface:Profiler"
The when i run pw-loopback nothing happens

I ended up installing pavucontrol but when I load it up i do not get the option to create a new loopback device

If you install goxlr-utility from AUR it should be possible to import profiles from the official
App on proprietary OS

GitHub - GoXLR-on-Linux/goxlr-utility: An unofficial GoXLR App replacement for Linux, Windows and MacOS
to import your profiles from the official app, simply click on the folder icon in the top right of the relevant profiles pane (either Main or Mic) which will open the directory in your file browser. Copy the profile across from the Official App’s directory (normally Documents/GoXLR) and they’ll appear in the util ready to load, simply double click them.

pavucontrol is just an audio mixer GUI for PulseAudio/pipewire-pulse and cannot load additional modules

pipewire-pulse supports pactl commands so it may be possible to load a loopback with:

pactl load-module module-loopback

Ahh okay so when i do load-module module-loop back' i get the following 536870913` do you know if this is normal or should i got back to pulseaudio?

And ill go ahead and load up my profile from my windows drive.

I tried it but I still can’t control my audio from my goxlr mini while using my bluetooth heapdhones

I think i found what i was looking for and hopefully you can assure me but would i have to create a sink and then that would allow me to accomplish what im trying to do?

for PulseAudio pactl usually responds with the module number, so I would suspect the number is to identify the module within PipeWire

to check if the loopback-module is loaded

pactl list modules short

The loopback should also be visible in the Recording tab of pavucontrol

would i have to create a sink and then that would allow me to accomplish what im trying to do?

To create a null-sink for mixing audio sources try this:

pactl load-module module-null-sink

Not sure if this will work on PipeWire so you might need to find the equivalent pw-cli command