Pinephone update issues

I’m a new user. I had updated the mirrors y’day. Out of the box it refused to update anything, looking through the forums I was able to overcome several different error messages. Left it overnight to update, and was pleased to see the splash screen in the AM. It doesn’t look like a proper phone screen, looks like a desktop to me, although the session claims to be wayland mobile. But no keyboard on the screen, it won’t accept the password, just goes back to the splash screen. Although it doesn’t reject it either.

Using the dongle and a keyboard, I am able to log into the terminal.

At this point I’m not even sure what I installed, it does’t recognize the commands I was able to find to try and reveal whats under the hood.

This is what I get most of the time, trying to update.

error while loading shared libraries: cannot open shared object file: No such file or directory

Here was the proposed solution from Yochanan. : pacman -F core/libxcrypt-compat 4.4.28-2 usr/lib/ But it didn’t work for me. Possibly out of date?

Any tips or suggestions, thank you in advance.

Welcome to the forum! :wave:

Go back and look wherever I posted that and read the rest. :wink:

here’s the thread.

Not a whole lot there following your reply.

Let me execute the command again and I will copy what I get.

(ran up the hill and bought a cheap monitor, tiny print on the phone screen) One more reason I am determined to make this pinephone work. The dongle has ports for two usb, power and a monitor. pretty cool.

What was returned was this : warning: database file for ‘core’ does not exist (use ’ -Fy’ to download)

same message except instead of ‘core’ was ‘extra’, and a third with the word, ‘community’.

So I substitute -Fy for -F. Need to be root. OK. Sudo … back to the beginning.

error while loading shared libraries: cannot open shared object file: no such object or file.

So naive me thinks, well, yeah, install libcrypto, but it feels like I can’t install libcrypto if I don’t already have it. Sort of a catch -22.

sudo pacman Rncs Catch -22. didn’t work either, (joke)

Thanks again in advance.

No, nothing there except someone asking to clarify what I meant and I confirmed they were correct. :wink:

Thank you for your reply.

I honestly do not understand your reply.

I have tried as many of those commands as I could find.

I am kind of feeling like your trolling me now.

If so, just please block me, I’m just trying to figure out this new phone.

I’m trying to point you in the right direction so you can learn yourself. The answer is in that thread. My reply that was marked as the solution was only a hint and the replies that followed clarified.


man pacman | less -p '-F, --files'

…look for packages owning certain files or display files owned by certain packages

The name of the package is in that thread. :wink:

ok, thank you.

I’ll try again tomorrow.

Likely I just re install the entire thing from a boot. Which is above my pay grade, but I will persist.

Yeah, I did try man, man man too. man -h
I have tried every everything I know, and then some things.

I have no ideas left.

Anyway,I don’t mean to be cross or obnoxious, just want to get this phone to work.

Thank you for your reply.

I think you will need to find the openssl-1.1 package (e.g., openssl-1.1 (aarch64) | Packages | Arch Linux ARM) and manually unpack the missing to get pacman running again. Then you can sudo pacman -S openssl-1.1 to properly install the package.

But since you are trying to upgrade an ancient image that still used OpenSSL 1.1, you are probably better off just getting the latest Manjaro ARM Plasma Mobile (or Phosh if you prefer that, but Plasma Mobile is what was preinstalled if you got the PinePhone directly from the Pine Store) image for the PinePhone and dding that. (The recommended method is to dd from a computer, using JumpDrive on a MicroSD card inserted into the PinePhone to make it appear to the computer as a USB mass storage device.)

No need for that. Use pacman-static, that’s what it’s for. You can download it from a mirror like, copy it to your PinePhone and try again.

@Skylar I apologize, it seems I misunderstood what was happening. While my solution in the other thread is technically related, it does not apply to your situation.

Thanks. I have seen this solution suggested other places, it certainly seems reasonable.

For a beginner, I think the one thing I would like to not have broken would be the package manager.

Thanks for that. Its going to be some study for me to make that happen, the concept of copying pacman-static to the phone is simple enough, obviously needs to be done by hand.
As I noted, the splash screen looks like a desktop version, I don’t understand that. I am using a desk monitor for tty, since the phone screen is really tiny, all good until I’m 25 or so lines in, then I am below the bottom of the screen. Dumb problem I haven’t found an answer to, tried as many solutions as I could find. So I just cycle the power. So another pebble in my shoe.

Thus it may be a better solution for me to just flash a micro sd, and proceed from there. More hardware to buy, but only 10 bucks so ok.

I came across this discussion on another site.

Thankyou again for your replies.