Pinephone terminal app wont start under plasma mobile

hello i have a pinephone and if i start the terminal app it just shows a blank desktop after 15 seconds
and i can press the close button or go to the menu with open apps and click on the not open terminal and the desktop shows again and all other apps work without problems, i have acces to the command line over serial and ssh

Yeah, this is happening with mine too.
It was working normal before, but one of the last updates have broken something. (I believe)

I can’t reproduce this issue on current stable branch.

But I did see something similar a little while ago. But the issue is no longer present.

After I upgraded, the terminal icon was being displayed for a moment and stop. I found out gnome-terminal wasn’t installed. After installing it, the terminal is there (I can see it when I hit □), but it doesn’t stay in the foreground.

However, if I run it from an ssh terminal, I get a working terminal on the phone, although on the PC it says:

[ale@alesmart ~]$ DISPLAY=:0 gnome-terminal
Authorization required, but no authorization protocol specified

# Could not open X display

What shell (“desktop environment”) are you running on your PinePhone? Plasma Mobile normally uses QMLKonsole (qmlkonsole). Phosh normally uses GNOME Console (gnome-console). Neither defaults to gnome-terminal, which is designed for desktops (as is the regular, non-QML, Konsole). You are better off using one of the mobile terminals, probably the one designed for the shell you are actually running. (So, since this is the Plasma Mobile category, I guess that this should be qmlkonsole at least for the original poster.)

I agree gnome-terminal is not quite usable. How do I switch to qmlkconsole? I have it installed but I don’t seem to be able to see it on the phone screen.

I tried editing the Exec line of /usr/share/manjaro/applications/org.gnome.Terminal.desktop but it didn’t work. So I deleted the file. After a while, a different terminal icon for gnome-terminal-server was added to the screen. I searched all *.desktop file and didn’t find one containing gnome-terminal-server. How does that work?