Pinephone manjaro arm phosh beta 12 sms not working

hello, just installed phosh beta 12 after problems with the beta 11 updates and chat/sms doesn’t seem to be working as it did on beta 11. tried to message myself, which worked fine on beta 11 but on beta 12 it adds a ‘1’ before my 10 digit phone number (it’s a local message to myself). the message gets sent but i don’t receive anything as i would before!? any thoughts? thanks.

What happens if you use a fully qualified phone number for yourself?


  • +
  • country code
  • area code
  • phone number


thanks for the reply, i’m in canada so my understanding is the ‘1’ is for canada. i also missed the fact that it added a ‘+’. so the chat messages i sent to myself (and didn’t receive) are, ‘+1XYZXYZZ’. i can’t for the life of me figure out why the chat program is adding auto-magically a ‘+1’ to the numbers i input. i’m almost 100% sure it didn’t do this on phosh 11! i called my landline with pinephone phosh 12 and that worked.

I’ve reclassified your question into the #arm:technical-assistance category so people more familiar with the Pinephone will read this…


I found two commits that discuss country codes, though these may not be related to your issue. I thought sharing them here might provide at least some help with this.

1 Like

thanks for the effort, it now looks like the country code is not the issue but receiving sms messages in general. i put the sim card back in the blackberry and everything worked fine. also worked in phosh 11 so it really is beyond me at this moment.

I just installed all the available updates for Manjaro KDE Mobile to the Pinephone that arrived today and was not able to send SMS messages either. The KDE message apps say they cannot detect a modem. @Rainer, what app were you trying to use? Has someone used an app that is currently working? Someone in an earlier thread was using Modem Manager Gui, and it did seem to detect a modem, but it looks so clunky for messages I didn’t spend the time to try to get it configured and working.