Pinephone disable vibration

Hello all,

I noticed that PinePhone with Phosh is vibrating for every icon, keyboard, etc. press.
I don’t like it + It consumes battery life.

I find-out that the issue can be solved when silent value is set for feedbackd service, cmd: gsettings set org.sigxcpu.feedbackd profile silent.
This change also affects other applications in the phone e.g feedbackd configuration file is stored in /usr/share/feedbackd/themes/manjaro.json.

It seems that the vibration on press is set as default in the source-code ? I don’t see any settings for that behaviour in configuration file …

Also per feedback README (cannot post link yet) it should be possible to set silent just for some application based on the app id. However I’m not sure where to find app ID, for example for squeekboard?

Example from README:

GSETTINGS_SCHEMA_DIR=_build/data/ gsettings set org.sigxcpu.feedbackd.application:/org/sigxcpu/feedbackd/application/sm-puri-phosh/ profile quiet

Any ideas are welcomed.
Thx

For squeekboard it’s sm-puri-squeekboard (as documented here). Setting that and Phosh to silent will probably get rid of most if not all haptic feedback on pressing buttons.

1 Like

Awesome thanks. I tried that before but I used quiet instead of silent :man_facepalming:

ID for squeekboard is sm-puri-squeekboard.
If anybody else will dig it out here is the correct cmd:

gsettings set org.sigxcpu.feedbackd.application:/org/sigxcpu/feedbackd/application/sm-puri-squeekboard/ profile silent

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.