Pinephone can't connect to WIFI

Hey,

I received my Pinephone Manjaro edition and I can not seem to get it to connect to my wifi router.

When I try to connect to my router, I enter the password (which I have checked is correct). It tries to connect and then re-prompts for the password again as if it was the wrong password. I have confirmed that it is infact the correct password.

The router is a D-Link DIR-878
The security on the router is set to WPA/WPA2-Personal

If I set the security on the router to none, I can connect just fine
I can connect to my macbooks wifi hotspot with WPA/WPA2-Personal
I can connect to my android phones wifi hotspot with WPA/WPA2-Personal

I tried the following Phosh builds with no luck

  • phosh beta1-20201029
  • phosh beta1-20201016

I thought that this could be an issue with the gnome keychain so I tried the following builds also with no luck:

  • Lomiri build (can’t remember which one)
  • 2 different KDE versions

journalctl -u NetworkManager says
“access point ‘SSID’ has security, but secrets are required”

I was able to get a wifi connection working with connman, which allowed me to switch to the testing branch and update but still no luck with NetworkManager on the testing branch. After a certain amount of time connman stops working and it’s not a great solution for a phone, but it does mean that the wifi does in deed work and it seems that NetworkManager does not like my router for some reason.

Finally I tried this with PostmarketOS to see if it was potentially an issue with the phone or router but PostmanketOS works fine so it would seem to me that the issue must be software related and not the phone or router.

Any ideas from anyone on how might go about troubleshooting this issue?

Thanks

1 Like

Hello,

I didn’t received mine yet, but make sure you open the phone, from the back cover, and remove the tape that is there.

Yup I have removed the plastic on the battery, and I suppose it’s also worth mentioning that I have double checked the wifi switch on the back of the phone and confirmed that it is enabled.

And still no joy?
@philm - do you know something about this?

WPA2 is enabled? With AES/TKIP or AES security? DHCP is also enabled?

I had trouble connecting to my Wi-Fi when 802.11r was enabled.

WPA2 is enabled but I do not know what the cipher type is because the router is using a newer (neutered) UI without much configuration. I have reached out to D-Link to see what cipher type is used. In the mean time I will try to find out from the web.

DHCP is enabled

The 2.4GHz network only supports 802.11b/g/n

I was able to turn on the “Guest Zone” feature of the router and successfully connect to the router with a password but because this UI is so minimal I don’t actually even know what security mode is being used, so I’m not sure if its WPA, WEP, etc. The UI on this thing is terrible for anyone that wants to be able to fully configure the device.

This weekend I’m going to tweak the settings on the router to try to see if there is a setting scheme that will work and will report back. My wife isn’t super happy when I keep changing the settings and booting her off the network LOL.

D-Link support says

WPA uses TKIP.
WPA2 uses AES

iw wlan0 scan says

WPA:	 * Version: 1
	 * Group cipher: TKIP
	 * Pairwise ciphers: TKIP CCMP
	 * Authentication suites: PSK

one thing that is interesting is I noticed my neighbors wifi says

WPA:	 * Version: 1
	 * Group cipher: TKIP
	 * Pairwise ciphers: CCMP TKIP
	 * Authentication suites: PSK

The pairwise cipher is revered. I’m not sure if that makes a difference at all but I just noticed it.

I also tried to change my wifi secuirty mode to
WPA2/WPA3-Personal
WPA3-Personal

and NetworkManager says that Authentication type of wifi network not supported and the iw wlan0 scan does not have a WPA section. My guess is it’s … not supported.

Is TKIP supported? Is it possible that my router is is asking to use TKIP first and it’s not supported and not falling back to CCMP?

I’m far from a networking specialist so I’m grasping at straws here.

I was able to successfully connect to the wifi with wpa_supplicant so it really does seem NetworkManager does not play nice with my router. I may try going back to DD-WRT, which is what I had used since I bought the router, but I had issues with momentarily dropping connectivity. Not a huge issue normally but since my wife and I are both working from home these days, I can’t have an unstable internet connection while hosting a meeting.

Anyway, if anyone has any more suggestions please let me know, I appreciate the help.

TKIP is hacked, therefore it is better NOT to use it!

All other of Your configs look correct. I hope You have no “Umlauts” in Wlan name or password?

1 Like

no “Umlauts” in Wlan name or password.

I noticed I have the same issue on Arch ARM as well but no other distro seems to have this issue

I guess this will be the final update. I installed DD-WRT on my router again and everything works fine. I’m not sure what the issue was but some kind of incompatibility between the D-Link Dir-878 and Arch / Manjaro.

I have the same problem as you. Using WPA2 (AES) on a TP-Link mesh WiFi network. Will try Eduroam a bit later to see if I can connect to that.