PineBook Pro seems to go to deep sleep, but doesn't wake up


I have just installed the latest Manjaro arm for pinebook pro 22.06 and am using tow-boot 2021.10-004.
I have tried external mice, pressing all keys, the power button, touchpad etc. but the only thing that makes the pbp turn on again is holding the power button to completely turn it off and pressing it again to turn it on.

am I supposed to install anything, change the config?

if anyone has any ideas on how to fix sleep I would really appreciate it.

output from

journalctl | grep suspend

avg 09 18:00:28 nik-pc systemd-sleep[8619]: Entering sleep state 'suspend'...
avg 09 18:00:28 nik-pc kernel: PM: suspend entry (deep)
avg 09 19:12:35 nik-pc systemd-sleep[6152]: Entering sleep state 'suspend'...
avg 09 19:12:35 nik-pc kernel: PM: suspend entry (deep)
avg 09 19:24:39 nik-pc systemd-sleep[1343]: Entering sleep state 'suspend'...
avg 09 19:24:39 nik-pc kernel: PM: suspend entry (deep)
avg 09 20:09:25 nik-pc systemd-sleep[1595]: Entering sleep state 'suspend'...
avg 09 20:09:25 nik-pc kernel: PM: suspend entry (deep)
avg 09 20:20:49 nik-pc systemd-sleep[1808]: Entering sleep state 'suspend'...
avg 09 20:20:49 nik-pc kernel: PM: suspend entry (deep)
avg 09 20:23:50 nik-pc systemd-sleep[1136]: Entering sleep state 'suspend'...
avg 09 20:23:50 nik-pc kernel: PM: suspend entry (deep)
avg 09 20:37:46 nik-pc sudo[1058]:     nikd : TTY=pts/0 ; PWD=/home/nikd ; USER=root ; COMMAND=/bin/systemctl suspend
avg 09 20:37:47 nik-pc systemd-sleep[1082]: Entering sleep state 'suspend'...
avg 09 20:37:47 nik-pc kernel: PM: suspend entry (deep)
avg 09 20:47:23 nik-pc kernel: PM: suspend entry (deep)

this is my /etc/systemd/sleep.conf

#HibernateMode=platform shutdown
#HybridSleepMode=suspend platform shutdown

Tapping the power button works for me. I am using kernel 5.19.0-1 on the unstable branch, that may make a difference.

I have the same issue, but running kernel 5.19.1-2 (stable branch). I do wonder if it is related to running full disk encryption…

I’ve tested this in both scenarios with and without encryption. And sadly it simply doesn’t work for me with kernel 5.19.1-2. I’ll probably try the kernel from unstable to see if it makes any difference, but feels kind of weird.

So tested with unstable with the result of loosing quite a lot of modules and suspend still broken.
I will try to do a diff of the 5.19.0-1 and current 5.19.0-2. There might be something that will point us to the correct direction.

Same problem after switching from the old linux-pinebookpro kernel (5.7.19-1) to arm-stable vanilla “linux” a few weeks ago (5.19.1-2). Then tried linux-lts (5.15.60-1) in hopes it would revert whatever prevents waking from suspend, but no such luck. Still broken with linux-lts 5.15.67-1.

I got suspend to work on the linux-pinebookpro kernel after installing mrfixit’s uboot using dd (although a frustrating percentage of suspends, it would wake up but then stay stuck with nothing but a movable pointer on a black background).

Is anyone able to bisect the versions where it stopped working (maybe per Yochanan above, between unstable 5.19.0-1 and later stable 5.19.1-2)? Seems like a recent change broke this if it was working as recently as 5.19.0-1.

Sorry for reviving this old topic.

But I have this same problem. Maybe there is a simple fix already, and then I’d like to know! Maybe it is still a problem, and then I may have a simple workaround.

I “solved” this issue by following (part of) a guide (I’m not allowed to link to: howtogeek com/devops/how-to-hibernate-or-sleep-linux-from-the-command-line ) to change the default suspend mode to the lighter s2idle mode. It is probably not as good as a full mem or disk suspend, but for now it at least functions.

This change requires only one command:
echo s2idle | sudo tee /sys/power/mem_sleep

Edit: Apparently this change doesn’t survive a reboot. I’ll reply here if I figure out how to make it more permanent. Battery usage in this mode doesn’t seem too bad, in the first test, 7 hours of idling took about 50% of battery.