Pinebook Pro NVME boot seems to disable SD boot

I updated the SPI flash on my Pinebook Pro as described here, Releases · pcm720/rockchip-u-boot · GitHub

Now it boots fine from NVME but if I insert a SD Card which is supposed to take priority over NVME it doesn’t power up and boot until I remove the SD card. I built the SD Card using the Manjaro ARM Flasher utility on the Pinebook Pro running 20.08

Found a newer version here Releases · pcm720/u-boot-build-scripts · GitHub

Trying that one, to see if it fixes the problem booting from SD

1 Like

Yup, the later one worked and has the added advantage of using the LEDs the same way the factory one did. Amber then Green as opposed to off and then Green.

1 Like

So when you used U-Boot v2020.07-1 it worked fine?

How did you go about getting Manjaro on the NVMe? I’ve just installed a NVMe drive on my PBP and am pondering my next move.

I followed this guide with much success: PineBook PRO - Manjaro 20.0.4 - NVMe - General Discussion - Manjaro Linux Forum

1 Like

I used the Manjaro ARM Installer on the Manjaro booted from SD.

1 Like