Pinebook Pro botched Manjaro I3 install


I’m having a hard time to install Manjaro I3 (20.08) using manjaro-arm-flasher.

What I’ve done:

  • flashed I3 to SD card with arm-flasher
  • booted SD card, ran system update, installed arm flasher
  • erased partitions on EMMC with gparted and flashed I3 onto it

Now the PBP does not power on without SD card and does not boot from EMMC.

With SD card inserted it boots I3 from it, but the network manager does not find any network devices, though everything worked properly after creating the SD card.

Do I now own a PineBrick Pro?

Try this Manjaro ARM 20.08 released!

No, very unlikely that it’s bricked.

The problem is often that the original Rockchip boot-loader starts emmc first and then sd-card. For a laptop not so helpful.
The distros add another bootloader to the EMMC that is loaded first and that one then checks the sd-card first and if nothing is there boots from EMMC.

The problem is now that this EMMC-bootloader seems to get damaged more often than you would like. I had it once or twice as well.

I don’t know how to fix your specific case, but there are several threads with help in forum pine64 org and and some articles in wiki pine64 org (unfortunately in this very moment they are down for a short maintenance)

I’ve tried this but it still won’t power up without SD card inserted.

Well, you will need to have a SD card inserted to get a working OS
When you take back off, there is a switch that shorts emmc clock,
so that you can leave emmc in, but it is non-functional
When booting from SD, there is a 2 second window to turn emmc
back on (flip switch to original) or the unbind/bind trick if you missed
Then you can repair uboot, opinions differ which is best
I prefer mrfixit’s, updated of course
you can buy an emmc carrier, pull emmc, repair on another computer