Pine Phone Manjaro with Phosh won't start after update

I ran updates yesterday and now the phone won’t start: there’s an error screen with:

Ooops! something went wrong.

I have the system installed on the eMMc. When I chroot into it and run updates:

pacman -Syyu

there’s nothing major being pulled and system still won’t start.

Looking at the journalctl -b -1 logs there’s this line repeated over and over:

gnome-software (...) gdk_monitor_get_scale_factor: assertion 'GDK_IS_MONITOR (monitor)' failed

If I recall correctly the last update had something to do with libhandy1 and/or pinephone-manjaro-tweaks.

I could do with some advice on how to fix this

looks like not chrooting and instead running:

packman -Ss --sysroot /dev/mmcblahblah and packman -Su --sysroot /dev/mmcblahblah 

fixed it? System starts now… (but how?)

I’ve edited your post a bit for readability and re-classified it under the #arm topic so the right people can have a look at this.


1 Like

I think you’d just want:

pacman -Syyu

to replace the above commands.

1 Like

Done. I was wondering why myself, but left it in for OP to verify…