Phosh Online Accounts settings module cannot connect to Google

EDIT: I realized I framed this slightly wrong. This really isn’t about the Calendar app at all. It is about the Settings app and the plug-in or whatever the Online Accounts module uses to connect to Google for authorization, which Google rejects as an outdated browser. Therefore, any app requiring a connection to Google will not be able to connect since the all rely on this settings module. I’ve changed the title of the thread to reflect better where the problem lies.

Original post follows…

I don’t know if this happened with the latest update or if it is just something I didn’t notice. Before this update, power handling was a bit sketch between the Pine Keyboard Case and the PinePhone (Beta, not Pro), but after this update power handling has been a dream so I am really trying to use this setup as a part of my workflow if not a daily driver.

As part of my workflow, I need the calendar syncing with my Google calendars, which it seemed to do when I set it up last year., but I haven’t checked it much lately. When I checked just now, it wasn’t updated and syncing made no difference. So I checked “online accounts” which sends you to the settings panel for managing them. There, it shows my google account, but tells me “Credentials have expired, Sign on to enable this account” Okay, I hit the sign in button and a Google dialog box pops up for me to type in my email. The first problem is that the text field won’'t accept any typing, from either the hardware keyboard or the on-screen keyboard. Okay, I get around this by typing what I need in a text editor and pasting it. Google even messages my Moto phone alerting me to a new attempted login, But when I have pasted in my password and hit the button, Google tells me “Couldn’t sign you in. This browser or app may not be secure. Try using a different browser.”

I tried signing in with Firefox (worked fine) hoping that then maybe Google wouldn’t care about the settings plug-in, but no joy.

So any program that goes through the settings module for online accounts is going to run into the same problem. However, the problem being with settings and not individual apps may make it easier to fix in an update.

I have to have google calendars. Is there any way around this for now or am I missing something obvious that I am doing wrong (always my first hypothesis).

TIA for any helpful suggestions.

1 Like

I don’t use phosh and I’m not sure this will work and it’s a suggestion: If there is a calendar application adding the calendar manually should be an option, this is the option I used when having a issue with gnome-online-accounts.

I have the same problem. It looks like a general problem introduced with the latest Phosh:

Settings → Online Accounts
Google → Sign in

Opens a modal browser context, but it’s impossible to type in the “email” input box. If you type it elsewhere and paste, you get the error described above.

So, this applies to all Google services: mail, calendar, contacts, photos, files, printers.

I realize there are probably hacks for each, but I’m eager to know if this is Google mucking with their authentication, or a regression in Phosh, and what a good system-wide fix would be.

2 Likes