Phone Mounts Read-Only

I’m running Manjaro-Plasma on a Lenovo PC, and when I plug-in my Samsung Galaxy S7 phone, the phone shows up in Dolphin, but not “mounted”, rather as network protocol “mtp:/”, and mostly-read-only (I can read, copy, and delete files, but I can’t rename, edit, or paste files).

I did some research and found that package “simple-mptfs” supposedly allows full read/write access. So I installed that.

However, I can’t get it to work. The command line is supposed to be “simple-mtpfs source mountpoint [options]”. So I set up a mountpoint at “/rem/Galaxy”. However, i don’t know what to write as “source”. The phone isn’t showing up in lsblk that I can tell. There’s only two unmounted entries: “/dev/sdd” (SD card jack) and “/dev/sr0” (CDROM). So how do I tell simple-mtpfs what the “source” for my phone is? (I tried leaving the source blank but it complains “can’t mount a NULL device”.)

Or is there some other way to mount my phone to a folder?

A phone cannot be mounted as a storage device, because then the phone’s own operating system would no longer be able to function properly. That’s why the MPT protocol was invented, and it is a protocol, just like http and ftp.

The write access problem is due to the fact that you did not allow file transfer on the phone itself when it was connected to the computer.

Ok, that makes sense.

This is not true. Until I allow access by tapping “Allow access: Yes” on my phone, the phone shows up only as “This Folder Is Empty” in Dolphin. After tapping “allow access: Yes”, then exiting-and-re-entering Dolphin, all of the contents of the phone are now visible, just “read-or-delete-only”, no editing or pasting allowed. (I have no idea why deleting files and directories is allowed, but editing or pasting files isn’t allowed; I find that bizarre.)

Same when I try to use various MTP apps in Linux (“simple-mtpfs”, “mtpfs”, “Android File Transfer”): If I don’t tap “Allow Access: Yes”, the apps fails with “access denied by user!” or similar.

But when I do allow access, the apps either immediately silently fail-and-exit (“simple-mtpfs”), or silently hang as if stuck in an infinite loop (“mtpfs”). Except for “Android File Transfer” which says “MTP already in use, perhaps by KDE or GVFS”.

So, no, it’s not a permissions issue, it’s something else.

In the short-term, I had to result to using Microsoft Windows 10, which allows instant full “read, write, copy, paste, rename, edit, save” access to my phone with no questions asked, and even without the “Allow Access? Yes/No” box popping up.

But in the long term, I’d like to be able to do this through Linux. I’d hate to think that “Linux can’t talk to phones”. Hopefully the problem isn’t that drastic.

Deleting a file and creating a new file are write operations on the directory containing the file, not on the file itself. Being able to modify a file’s contents is a permission on the file itself. So therein lies the difference.

However, I do not know why you’re having this problem in Manjaro and not in MS-Windows. :thinking:

1 Like

Ok, firstly an update: Since I last wrote, “paste” has started working. Couldn’t paste yesterday, can today; go figure. (I have no explanation for that, as I changed nothing.)

Also, “edit in-place with app” is now working. Basically, the working / not working stuff is now like this:

  1. Can edit text files on phone with an app (eg, Kate).
  2. Can “copy” files from phone to computer.
  3. Can “paste” to phone from computer to phone. (Yay!!! This was the main thing I wanted to do!)
  4. Can “delete” files on phone.
  5. Can’t “cut” files from phone. (Workaround: copy file from phone, paste to computer, delete file from phone.)
  6. Can’t “rename” files on phone. (Workaround: copy file from phone, paste to computer, rename on computer, cut file from computer, paste file to phone, delete original file from phone.)
  7. Can’t create new files on phone. (Workaround: Create new file on computer and copy to phone.)

Yep, that makes sense. Mirrors the restrictions on the “C:\” directory in Windows 8 & 10: Can’t create files there in-situ, but can copy them there from elsewhere.

Btw, my previous statement “it’s not a permissions problem” is maybe not true. When I enabled the “owner” and “permissions” columns in Dolphin, the “owner” of all files on my phone is [blank] (I don’t even have permission to see who the owner is, apparently), the directory permission are all “drwxrwxrwx”, and the file permissions are all “-r-xr-xr-x” (no write permissions at all!). This is kinda backwards from what I’d expect based on my can/can’t list above. Weird.

I’m guessing that Windows Explorer’s implementation of MTP just automates the “workarounds” I list above, whereas Manjaro-Plasma’s Dolphin doesn’t.

Btw, I verified that my spare notebook computer, running a pristine install of Manjaro-Plasma (installed just a few days ago) is doing all the exact same things. So this isn’t some fluke on my desktop PC; it’s just how Manjaro-Plasma’s Dolphin interacts with Samsung Galaxy S7 phones. I suspect it’s a Dolphin thing.

Of course that doesn’t quite explain why the three other MTP apps I tried failed to work. But that may be some combination of me using them wrong (their documentation ranges from “abysmal” to “non-existent”) and KDE’s own implementation of MTP interfering (as hinted by that one app that said “Error: MTP already in-use, perhaps by KDE or GVFS”).

But I now have workarounds! :slight_smile: So I can now copy stuff between phone and computer. Just, no renaming-in-place and no creating-in-place.

This is interesting, I appear to be having the same or a very similar problem s @ LoneWolfiNTj

I thought this was an odd issue, that I have never experienced before… at least not on the Gnome based Desktops I was using til recently.

So I thought I would check this out.

So I am unable to write any data TO the phone… I am unable copy or move files to the phone, I am unable to create new text files or new Folders, but I can delete existing files and Folders.

I’m using Dolphin on Manjaro KDE

Operating System: Manjaro Linux
KDE Plasma Version: 5.24.6
KDE Frameworks Version: 5.96.0
Qt Version: 5.15.5
Kernel Version: 5.15.60-1-MANJARO (64-bit)
Graphics Platform: X11
Processors: 4 × Intel® Pentium® CPU N3540 @ 2.16GHz
Memory: 7.6 GiB of RAM
Graphics Processor: Mesa Intel® HD Graphics

The phone is a Samsung Galaxy A50 - SM-A505YN with Android 11

Solved my problem… it was the USB hub I was using.

@ LoneWolfiNTj did you by chance have you phone connected via a USB hub

Have you tried this?

sudo pacman -S android-file-transfer android-udev gvfs-mtp libmtp && mtp-detect

That works for me.
In some cases (phones) you may have to reboot Linux after the mtp-detect command for the detection to work properly.

1 Like

This worked for me on my Galaxy 7; text files I created weren’t immediately visible, and at first I got error messages ( Couldn't create file TextFile.txt ), but the files were actually there and could be edited.
Thank you so much!

Btw: I didn’t use to run into the same issue with phones I had before -could it be Samsung-specific?

It’s possible, though I can’t say with 100% certainty. My old Redmi Note 5A was literally “plug & play” in Linux, whereas my current Redmi 9 (not Note 9, just 9) requires for me to do what I said in my previous post.

Oddly, I had the exact same issue. Transferring files to a Lenovo laptop from a Galaxy S7 didn’t work right, even after tapping “allow access.” I’ve since found a completely unrelated workaround to get all my pictures to a new phone, but it does seem like a strange coincidence.

My problem was that I was connected via a USB hub.

Nope. Straight cable connection to one of the two front USB2 jacks on my Lenovo desktop computer. (It also has USB3 jacks, but for some bizarre reason those are on the rear only.)

Yep, I tried all of those, and they all failed. And I’m pretty sure why: KDE has MTP tied-up for its own use. One of those programs even explicitly said, “Error: MTP already in-use, perhaps by KDE or GVFS”.

So, no, that’s not going to work. Not unless I wanted to abandon using KDE, which would be like cubing a car because it has a dent in a fender.

But like I say, I found workarounds. I can’t “create”, “rename”, or “cut” files on my phone. (I tried both Konquerer and Dolphin, and both are missing these 3 features.) However, I can “copy”, “paste”, and “delete”, so I use those as necessary to work-around the missing features. (I have to wonder why the Konquerer and Dolphin teams haven’t simply automated those workarounds, as Microsoft Windows apparently has.)