Permission to write on an NTFS hard-drive (share with windows)

Hi !
I use a stable and updated gnome-manjaro in dual boot with windows 10. I also have another hard-drive in NTFS, in order to share my files between manjaro and windows.
However, sometimes, after using windows, I’m no more able to copy/cut files on my hard drive. I just have read-only. DO you know how to correct this ?

Thanks :slight_smile:

Be sure Windows cleanly unmounted the partition before switching.
https://wiki.archlinux.org/index.php/NTFS-3G#Metadata_kept_in_Windows_cache,_refused_to_mount

1 Like

Use exFat, much less trouble.

Disable Windows Fast Boot. It doesn’t properly shut down your Windows filesystems, which leads the Linux kernel to regard them as potentially corrupted, and therefore, the kernel will mount them as read-only to prevent further corruption. :wink:

Actually, you are doing the wrong thing by sharing your data over NTFS. Your shared partition should be ext2 (not ext3/ext4/NTFS). Windows has ext2 read+write support via ext2fsd, which is stable and works really well. NTFS has many disadvantages: everything put on an NTFS partition becomes world-writeable and world-executable contrary to Unix permissions; NTFS performance under Linux/FreeBSD is slow.

A big thanks for all your fast answers ! I will try them !
So exFat or ext2 :slight_smile: ?