Permission issues writing/deleting to ext4 formatted HDD

I recently formatted a previously ntfs HDD to ext4 using Gparted, however when I try to edit something in that drive I get an error saying permission denied. I can however delete things through the terminal using sudo. There is also a folder “lost+found” which i did not place in there. I tried to find any other solution online but nothing worked.

This is normal on ext2, ext3 and ext4 filesystems. It’s where recovered files will be placed if the filesystem ever gets damaged and repaired with fsck.

1 Like

First is this your OS drive now or not. If not and it’s just for data that has nothing to do with your install I would just install rootactions and once installed rightclick a empty space in the partition go to Rootactions and give permission to active user. To add rootactions just install kde-swervicemenus-rootactions from the AUR. Adding it through Dolphin sometimes doesn’t work depending on the OS.

There’s no need to complicate things with AUR packages, I’d use the tools that are already available and work for everyone.

sudo chown $USER:$USER /path/to/mountpoint

It’s not complicated and I’m pretty sure you knew that before you made your post. Everybody has their own way of doing things and are allow to suggest them to others.

I’m not saying that installing the AUR package or using it is complicated.

I’m saying that it complicates things, ie that you’ve installed a middleman that adds to maintenance and potential breakage just to take care of something very simple that requires nothing extra.

There’s a reason the AUR is unsupported. If they’re not familiar with using the AUR then there’s more learning to do, and if they ever have a problem with it then I think the most likely reply would be to remove the AUR package and use chown/chmod instead.

Also your suggestion can only help those with KDE/dolphin, and some people will naturally not wish to install an AUR package just to perform a very basic task for which there’s no need for an AUR package.

Indeed and we’re also allowed to suggest alternatives, especially simpler ones that work for everyone. You’ll note that I correctly said “there’s no need” since there are already tools installed to perform that job.

It wasn’t an attack on your suggestion I was just trying to put it into proper context and suggest the way that I and (I think) most others would use. Perhaps my words were poorly chosen, they usually are.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.