Permission Denied in Terminal?

Hiya all, I’m trying to get Rocksmith 2014 to work with Manjaro. Game launches just fine however there is a mod I need to work (RSAsio) which allows me to use my audio interface instead of their propriety cable.
The mod has been confirmed working on linux however to use it I need to use wine asio and jack. Both of these are installed and working as I have Ableton Live running fine.
The mod sees wine asio but fails to open. I encountered this with Ableton and running the included “wineasio-register” fixed this. I’m now trying the same with Rocksmith and Proton however when I try to run it in the terminal I get this error
screenshot removed
Here I am running the wineasio-register scrip but directing it to protons prefix. I also tried with Rocksmiths prefix with the same result

However as you can see I have been denied permission as sudo and I do not know why. I have had this command run successfully without sudo when I was setting up Ableton Live with only difference being it has a different prefix located at “/home/skyler/Games/ableton-live/” (This was installed with Lutris)

I am at a loss and any help would be appreciated. I have also included my RSAsio log and Steam log from opening Rocksmith just in case

I am still a Linux noob so if I have missed anything please let me know :))


Upload screenshots to external image sharing sites and post the link to them here.

From what I know how wine works (or it’s derivatives):

it’s akin to a Windows installation

I don’t think that one can “link” two or more of these and have them work together.
It all has to be in one prefix - in one and the same fake Windows environment.

To get wineasio to work you have to register with each prefix you want wineasio running. I confirmed this by installing the windows version of steam into a new wine prefix in Lutris. I downloaded rocksmith from that and at first it didn’t work. However when I ran the wineasio register with that new prefix it all worked fine.

However for some reason I can’t do this with native steam installation as every time I run the same command (apart from where the wine prefix is) it fails.

I’m unable to attach the link to the screenshot so here’s the terminal output

sudo env WINEPREFIX=~ /home/skyler/.local/share/Steam/steamapps/compatdata/1493710/pfx/ wineasio-register
[sudo] password for skyler: 
env: ‘/home/skyler/.local/share/Steam/steamapps/compatdata/1493710/pfx/’: Permission denied

there is no screenshot
(post was edited in the mean time)


I still operate on my knowledge of what and how wine operates.

one prefix - not two or more interacting

and that is good
no screenshot needed :wink:

There’s a space between ~ and /home. You don’t need the ~ it means '/home`

sudo env WINEPREFIX=/home/skyler/.local/share/Steam/steamapps/compatdata/1493710/pfx/ wineasio-register


Just dropping by to say you probably should never use wine with sudo (or as root).

Doing so will also break your permissions.