Permanently enable mono audio (Pipewire)

Hey, if you were to look at my profile you’d see that I’ve asked this question before, but on PulseAudio

Now, I’d really love some advice if anyone knows how to enable Mono Audio (preferably without EasyEffects or a 3rd party tools)

I saw mono can be set as output …


context.modules = [
    { name = libpipewire-module-loopback
        args = {
            node.description = "Mono Playback Device"
            capture.props = {
            = "mono_output"
                media.class    = "Audio/Sink"
                audio.position = [ MONO ]
            playback.props = {
            = "playback.mono_output"
                audio.position = [ MONO ]
                node.passive   = true

You would then need to reload the use service(s)…ex:

systemctl --user restart pipewire.socket
systemctl --user restart pipewire-pulse.socket
systemctl --user restart pipewire.service
systemctl --user restart pipewire-pulse.service

(or restart)

Then you should be able to select this mono output device from your GUI system settings.


Thank you so much!
I’ve been using third party tools for so long & now they’ve stopped working

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.