Performance decrease with xmind8 in manjaro compared to ubuntu 20.04

@ manjaro kde-plasma
I’m using xmind8, it is a desktop application to create mind-maps.
I dual boot ubuntu gnome (hdd) and manjaro kde(m.2) and have xmind8 installed on both.

xmind8 runs slow on manjaro, considerably slower than on ubuntu.

ubuntu runs nouveau graphics, I ran nouveau on manjaro as well but switched to nvidia-470 to see if it helped with the performance of xmind but it did not.

I installed xmind form the AUR. When moving the mindmap it stutters heavily with both nouveau and nvidia drivers and cpu usage is really high, on ubuntu the moving is fluid for the same mindmap. Creating nodes is also slow on manjaro but on ubuntu it is instantaneous.

To install xmind8 on ubuntu I have to use repositories from an earlier version of ubuntu and install the packages (click to see list of files):

libcanberra-gtk-module : (libs): translates GTK+ widgets signals to event sounds
libwebkitgtk-1.0-0 :(libs): Web content engine library for GTK+

the whole install procedure in ubuntu is described here.
Xmind8 can be downloaded from here

this is what I installed form AUR

In the AUR page there is written about dependencies, I’m a n00b but to my understanding the only thing that is needed is either gtk2 or gtk3, I have:

% pacman -sS gtk3 | grep installed
extra/avahi 0.8+22+gfd482a7-1 [installed]
extra/gtk3 1:3.24.30-2 [installed]
extra/kde-gtk-config 5.22.5-1 (plasma) [installed]
extra/libcanberra 0.30+2+gc0620e4-5 [installed]
extra/wxgtk-common [installed]
extra/wxgtk3 [installed]
community/libappindicator-gtk3 12.10.0.r296-1 [installed]
community/libdbusmenu-gtk3 16.04.0-4 [installed]
community/libindicator-gtk3 12.10.1-9 [installed]
multilib/lib32-libcanberra 0.30+2+gc0620e4-5 [installed]

Now I wonder how I can debug the problem? The packages from the ubuntu installation, could that give some hints on what needs to be installed on manjaro? One thought I have is that perhaps the program should use gtk2 instead since in ubuntu I use packages from version 18 (bionic)? In that case can I just install gtk2 without having conflicts with the already installed gtk3, and how do I force xmind8 to use gtk2? i.e. do I put some argument in the .desktop file?

1 Like

Hi @hajonnes,

While I do not have the faintest Idea of what could cause this, I feel like I have to ask, have you tried the flatpak? And if you did, was it better or not really?

$ flatpak search xmind
XMind 8             Amazing brainstorming and mind mapping tool.           net.xmind.XMind8                      R3.7.9.201912052356           stable          flathub

So, it can be installed with (IIRC):

flatpak install net.xmind.XMind8

I have not tried flatpak. I mostly do not like containerized apps,
but I will try the install from flatpak and see if it performs better.

Thanks for the tip! :slight_smile:

The flatpak version has no performance issues.
It works perfectly but has some graphical artifacts.

I would like to know what is wrong with the AUR install because I use the program on a daily basis and like to have it without artifacts.
So if you have any debugging suggestions I’m all ears

But as I said flatpak is definitely a partial solution.

Very happy to hear that.

I believe it might be some kind of version problem. Or something of the sorts. But at the very least, it might give someone that knows more than me a clue as to what’s going on.

Well, thanks again for the tip! I’m much obliged.
Yes I think version problem could be the case since the installation in ubuntu calls for installing legacy software from an older ubuntu version and my installed packages have the same name but an newer version.
Also I noticed that ‘lib32-libcanberra 0.30+2+gc0620e4-5’ is a 32 bit library, could that be correct since I’m running amd64?
But I do not dare to touch anything until I get someone that knows something to look at it.

That shouldn’t be a problem, don’t worry 'bout it until someone who knows more than me tells you differently.

Neither do I - but of the lesser evil flatpak is to be preferred over snap - which - at least to my tests is a resource hog and very hard to get rid of once you wear out on it.

There is 4 different versions of xmind in AUR and none of them is version 8 but that may just be my lack of knowledge of this specific app.

xmind-legacy                                 3.6.51-4                 AUR 
    Brainstorming and Mind Mapping Software
    - legacy version 7.5
xmind-electron                               10.1.2-1                 AUR 
    XMind - The most popular mind mapping
xmind-2020                                   11.0.1-0                 AUR 
    XMind - The most popular mind mapping
xmind                                        3.7.9+8update9-1         AUR 
    Brainstorming and Mind Mapping Software

The gtk toolkits exist side by side.

The PKGBUILD building the xmind package is printing these lines at the end of installation

    Try to delete ~/.xmind/ directory if XMind crashes on start.
    Edit PKGBUILD and rebuild the package to change GTK or Java version.
    You can also set GTK version in the "/usr/share/xmind/XMind/XMind.ini"
    file on the line after "--launcher.GTK_version".
    You must add "" line at the end of the file
    if you are using Java version 10.

Specifically I noted the info on Java version - I don’t know if the message applies if you run a version lower than 10 or greater than 10 :slight_smile: I know now - you need your Java version to v8

sudo pacman -Syu jdk8-openjdk

Then list the environments installed

archlinux-java status

If the default environment is not java-8-openjdk you have to set it

sudo archlinux-java set java-8-openjdk

Tested on my system (X11) without any issues - so I am guessing you have a system configuration issue.

$ inxi -SG 
System:    Host: ts Kernel: 5.14.3-1-MANJARO x86_64 bits: 64 Desktop: Xfce Distro: Manjaro Linux 
Graphics:  Device-1: NVIDIA GP106GL [Quadro P2000] driver: nvidia v: 470.63.01 
           Display: x11 server: X.Org 1.20.13 driver: loaded: nvidia resolution: 1: 1920x1080~60Hz 2: 1920x1080~60Hz 
           Message: Unable to show advanced data. Required tool glxinfo missing. 

But as you mention nouveau and nvidia and you have tried both - one could suspect you are using Wayland and - at least that is what I believe I have read somewhere - Wayland and nvidia does not play well together but - also what I recall having read somewhere - that situation is being worked on by Nvidia. How well that is going to play out - I have no idea - I only occationally check on KDE environment - but I do see a lot of issues with KDE - that may just be due to the popularity of that enviroment.

But as you are using KDE (your profile says it) I have no clues on what to look for or where.

Themes sometimes creates issues if it is poorly constructed - but I can’t say - but you would know if you have used another theme than the default Manjaro - and if so - try reverting to the Manjaro defaults - logoff or restart - whatever you prefer - to ensure the theming are reloaded then test the app again.

1 Like

First thanks for replying and trying to sort out my problem!

The version number is written a little cryptic it is the ‘xmind 3.7.9+8update9-1’ which means ‘xmind8 update9.1’. I do not know what 3.7.9 means. Here is a link to it: I can not really tell if you used the right one but for the sake of moving the thread forward I assume you did.

I used:

pamac build xmind

and got no errors. I can start the program and it runs fine. When working with maps, creating nodes and moving the workspace in the window there is a very big difference to the one installed with flatpak, I have both installed at the moment.

You got a nice output form PKGBUILD. Would you say that it is a prefered method to install when you have to build compared to pamac?

I have just started to use manjaro. The install is just a couple of days old. So I do not think the settings I have are the problem if not manjaro uses some default option that is troublesome with xmind. I.e. I have not altered any settings, I just run default settings and default themes. As for graphics I’m running X11.

% inxi -SG
System: Host: johlux Kernel: 5.13.13-1-MANJARO x86_64 bits: 64 Desktop: KDE Plasma 5.22.5
Distro: Manjaro Linux
Graphics: Device-1: NVIDIA GM206 [GeForce GTX 960] driver: nvidia v: 470.63.01
Display: x11 server: X.Org 1.20.13 driver: loaded: nvidia resolution: 1: 1920x1080~60Hz
2: 3840x2160~60Hz
OpenGL: renderer: NVIDIA GeForce GTX 960/PCIe/SSE2 v: 4.6.0 NVIDIA 470.63.01

But your talk about building got me thinking. I looked in history and got this:
I installed jre8 at position 23 in history, built xmind at 51 but did not set jre8 as default until 130.

This must mean that I built xmind with java 11 and use java 8 to run it. Could that be the problem? pamac can not be so smart to use java 8 to build xmind if java 11 is set to default?

If I’m going to rebuild, is there any benefit with installing gtk2 before the build?

I did:
pamac remove xmind
pamac build xmind

some settings files must have remained after the remove becauce xmind have history of recently used files and it was populated. Did the program actually install or was the tarball taken form the cache?

Xmind didn’t become better. Still the same lag.

@linux-aarhus did you try to install a flatpack version and build a mindmap, basically you just use the tab key, and try to move it (middle mouse button) and compare it with the flatpack version.

It would be nice to know if it is my system or if it is the AUR package that no longer works with newer manjaro. The xmind8 version was put in AUR 2019.

The version number for AUR package 3.7.9+8update9-1 looks like an Ubuntu version number
so the package may have been recompiled for their use. Package was last updated 2019-12-26 05:25

Package xmind-2020 v11.0.1 was last updated 2021-06-28 04:52

I always install the jdk - which includes the jre.

Some versions of Java are LTS versions - and I believe Java 8 is one of these LTS.

I see in the official repo Java 7, 8, 11 and 16 indicating that 7, 8 and 11 is LTS and 16 is the latest.

On Arch based distributions Java is installed into /opt and a symlink to the relevant binaries are created in /usr/bin.

Some times for an app to work correctly the active jdk must be set - which is what the archlinux-java does. The script sets the Java version by pointing the symlinks to the binaries for the Java version to target.

But it may well be - I emphasize while I have been in close contact with Ubuntu through local c0ommunity - I don’t remember excatly which Java is available - the reason xmind is giving you issues on Manjaro but not Ubuntu is the Java installed.

On Arch-based distribution - Java is always the OpenJDK reference implementation. Maybe Ubuntu is using Oracle Java and if that is the case you could try building the Oracle Java also from AUR.

If xmind works with Java 8 then one would build and install Oracle Java 8

pamac build jdk8

Then use archlinux-java - first to list - then to set the Oracle environment.

No I did not - I have no use for the app - just curios.

I have downloaded a sample mindmap and it displays correct and I can move it around without issues.

Your comment in building using pamac - pamac shows message the same way in the console pane. Navigate to that pane by clicking the > in the lower right corner of pamac when building the package. To navigate away use the < in the upper left corner.

There is nothing wrong with the AUR PKGBUILD - but always bear in mind _AUR is created for Arch - not Manjaro - and your issue is an issue local to your system.

Because there is so many building blocks it is possible to do almost anything - but it is not every combination that work equally well.

I have been using Linux as my main system since 10 years and it was a tough and unpleasant ride for a while learning the inner workings of Linux. It only became pleasant when I found Arch Linux and Cinnarch - which later became Antergos - now EndeavourOS.

And Manjaro slogan is Enjoy the simplicity - but IMO this is related to the easy way of getting into the Arch Linux world - the maintenance of complex interwoven DEs like gnome and kde is still somewhat unpleasant - which is why I like my system to be K.I.S.S (openbox vm, tint2 and rofi) so I can focus on various real-life development projects - making real money - without fearing my system will act weird after an update.

I do not think the java version is at fault here.
I use OpenJdk 8 on both ubuntu and manjaro. And xmind works flawlessly on ubuntu. That I said jre was just because I was to lazy to write OpenJdk since I thought it is the jre that is important when running the program. My mistake since I build it as well and then perhaps the Jdk comes in to play. I do not know if, given this information I should try to install oracle java 8, what do you think?

The way I installed xmind on ubuntu-gnome and kde-neon is different thought. I just unzipped it and ran a script that installs fonts for the program. So now I wonder if I could use the same method to install in manjaro (install method)?

Thanks for the info. It is good to know what people honestly think, not just the polished answers that you get a lot when nobody wants to admit that their system is not perfect. :slight_smile:

I’m not sure. If you have not tried the flatpak version you do not know what to expect in terms of responsiveness. I too get it to work, and it behaves as it should but not as I’m used to. The sluggishness varies. You could do a test: If you hold down the middle button on the mouse and move the map fast around in a circle, and I mean fast. If you have no stuttering so the map jumps from one position to the next or freezes then you should be ok. Otherwise you have a sluggish version. I do not know how to reproduce the bug otherwize, but working on a mindmap it can become worse and worse so that creating new nodes takes a long time. The sluggishness of the panning is a reproducible test to see if it is something bad is going on or not though.
Also I have found that my splash-screen when xmind starts flickers once when I run the good version on ubuntu - gnome, flatpak, kde-neon, windows 7, but on the AUR version it is nice and do not flicker. Does your AUR splash screen flicker during start of the program?

Edit: The panning test can also depend on your hardware if you notice a difference or not… perhaps I do not know a test other than comparing to flatpak.

The performance and behavior of any named app is subjective as the circumstance will in almost any situation will be different due to environment and hardware.

I cannot reproduce your issue - but that is probably due to my system being - probably - considerably different from yours.

I recognize you have an issue - but I cannot point you to any viable options - mostly because I don’t use the app in question.

The only reasonable explanation is your graphics. I would look deeper into the configuration of your Nvidia card using the latest possible driver.

Use nvidia-settings to enable the nvidia compositor - disable whatever else is use - save it locally and run it using your xinitrc.

My workstation spec

  • Kernel 5.14
  • i9-9900K
  • 64G RAM
  • Samsung NVMe MZVLB512HBJQ-000L7
  • Nvidia Quadro P2000 (lastest Nvidia driver)

I ran
inxi --admin --verbosity=7 --filter --no-host --width
and got among others:

kernel 5.13.15-1-MANJARO x86_64
Intel Core i5-6600K
32GB Ram
NVIDIA GeForce GTX 960
Driver nvidia v: 470.63.01
M.2 SSD 970 EVO Plus 500GB rev. 2B2QEXM7, speed 31.6 Gb/s

I think both your graphics and your processor is singificantly faster than mine.
Still if you have the opportunity it would be very interesting to hear if your xmind flatpak and xmind AUR were performing differently. But perphaps you would not notice anything with your system power…

I will try what you suggested with compositor.

I tried to google what you mean, but I do not know what the nvidia compositior setting is in nvidia-config. could you explain verbosely exactly what to do, I’m a newbee.

I don’t know if it will work - but it was these settings I was referring to.

Ok thanks for the clarificaton.
the problem is still there unchanged.

I measured the gpu load using:

watch -n0.1 “nvidia-settings -q GPUUtilization”

When draging the map in a circle fast the AUR mind map just froze in one spot with a load peak of 24. the flatpak mindmap followed with the pointer when I moved it in a circle of equal speed as in the AUR. It peaked with a load of 60. Just moving the pointer in the same motion generates a load peak of 17.

It looks like the gpu does not get utilized as it should with the AUR installation.

I still think it might be the AUR that is out of date and not compatible with the newer file versions on an updated system and not my system settings, since installing on ubuntu you have to force download dependencies that are for ubuntu 18.04 to make it run on a 20.04 installation (see first post).
It would be so helpful if someone could install both the flatpak and the AUR version to see if they experience the same problem.

If you would feel up to it and have a manjaro installation that is up to date.
Install ‘xmind 8’ from AUR and flatpack.
Download the xmind map file: map.xmind, open it and try to drag it (use middle mouse button) in a circle fast in both the AUR version and the flatpak version and see if you notice any performance difference. Post your result here.
Thanks a lot!

I have installed GTK2, and edited the file

changed the GTK version to 2 instead of 3, so it looks like this:

Now it works flawlessly!!
I still have the composition enabled that linux-aarhus suggested.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.