PCSpecialist Laptop: Super key (META) is not working anymore

Hi people, I don’t know what happened but now I’m trying to use the keyboard meta / super and is not opening my launcher. Same when I’m trying to press meta + L to block my laptop.

Was working yesterday when I did a fresh install.
I tried a lot of things that I read in internet or this forum but nothing is happening.
I’m trying to assign as I have read in a lot of places adding meta+f1 but when I’m pressing only detects F1

meta not detected.

Also I tried adding running this command:

kwriteconfig5 --file ~/.config/kwinrc --group ModifierOnlyShortcuts --key Meta "org.kde.plasmashell,/PlasmaShell,org.kde.PlasmaShell,activateLauncherMenu" 
qdbus org.kde.KWin /KWin reconfigure

Someone can help me please? I’m frustrated :frowning:


What you could try is the following… :arrow_down:

  1. Log out of Plasma completely.
  2. Log in at a tty.
  3. Issue the following commands…: :arrow_down:
rm -f ~/.local/share/kded5/keyboard/session/layout_memory.xml
mv ~/.config/kglobalshortcutsrc ~/.config/kglobalshortcutsrc.bak
kbuildsycoca5 --noincremental
1 Like

Set it to Alt+F12
This should also make Super or Meta open the launcher.

I did and is not working yet.

I will try with @Aragorn’s method

Thanks for your fast reply. If you have more tips, i will try all.

By the way, also check whether you still have the application launcher (or one of its alternatives) on your panel. It won’t work without that.

Another useful tip is that you can add the application launcher (or one of its alternatives) to one of the hot spots on your desktop, i.e. one of the four corners or one of the four sides. That way, when you move the mouse onto that hotspot, it’ll pop up the launcher.

Thanks I tried and nothing.
I received this error

I want to avoid do that method because yesterday all was working perfectly.
I didn’t change anything except resolutions displays, fonts, icons.
I did a fresh install 2 days ago and was working.
Is like the button is not detected because I’m pressing in shortcut keys and is not showing :frowning:

That’s just an error about a bad .desktop file. It doesn’t have any effect on the keyboard settings.

I hope someone can tell me another idea.
Really it’s very weird. Or a way to reset keyboard settings by default is it possible? But I don’t change anything about keyboard.

Should also work.

But it more sounds as if your Meta or Super key is not being recognized at all.

The first two of the commands I gave you higher up do exactly that — they reset your keyboard settings back to the defaults.

There are several threads here at the forum regarding the same problem, but it’s usually reported by people running GNOME. I wouldn’t be surprised if it turns out to be Wayland-specific. :thinking:

1 Like

I’m thinking the same. It’s like the keyboard is broken or something but the laptop it’s new. I bought 3 days ago and yesterday was working perfectly. :frowning:

It might be Locale depended, because his setup might be using a different Layout as the default US keyboard layout…

He could check using showkey on a console.

PS: When using a Wayland Session the first console could be at Alt+F3 because the first two are already taken by the GUI…

I don’t think so. The Super/Meta key is normally locale-independent. It rather depends on the keyboard type.

Some keyboards don’t have a Super/Meta key, so it’s important to check if the correct keyboard type is selected in… :arrow_down:

System Settings → Hardware → Input Devices → Keyboard.

In most cases, the generic 104-key or 105-key keyboard is the correct choice.

Not just with Wayland. It’s actually the current version of sddm that plays out the Heisenberg Uncertainty Principle with the ttys, regardless of the display protocol.

Supposedly this has been fixed in the next version, but who knows? :wink:

1 Like

Yes, I did, and also I tried to change to 105-key and 105-key with shaped L Enter key and is not working :frowning:

I installed xorg-xev to detect when I’m pressing a key and detects all my keys except when I’m pressing meta

The only thing I can still advise at this point is to try with a different user account. If it does work there, then the problem is some file(s) in your home directory. If it does not work in the other account, then it’s likely a hardware issue. :thinking:

I did right now. I have created a new usert testing and it’s not working.
I don’t know if it’s good idea boot manjaro from stick usb and check there if it’s working.
Really I can’t believe this is happening. I didn’t move the laptop, and I was installing all my things (react native, java, icons, fonts).

I don’t think it’s hardware related because the laptop has only 2 days

While rarely the case, coincidences do happen. Likewise, it can be a faulty key-switch, or even keyboard…

1 Like

That would indeed also be a good test.

Unfortunately, doing all that can lead to some of Plasma’s configuration files getting corrupted.

It used to be more robust in the past. If a configuration file was corrupted, then it would automatically discard the file and fall back on the default values. But somehow it doesn’t do that anymore since they’ve rewritten large parts of it in QML.

1 Like