PC won't boot unless manually changing TPM setting

Basically, every time PC boots, I have to go to bios and manually change TPM setting from firmware to discrete or PC won’t boot.
This happened after I swapped mobo, cpu and ram.
Found similar case, but without answer: Question - Windows won't boot unless change "Firmware TPM" to "Discrete TPM" in the BIOS ? | Tom's Hardware Forum

What do I do so my pc would start without me going through bios and changing TPM setting?

Have you already tried:

  • change TPM-Setting
  • save configuration
  • boot

The problem is, it resets back to firmware on every boot, so i have to change it.

Are you sure you did

…this? Because, this:

…doesn’t quite sound like it…

Yes, I’m sure. Things like xmp and OC settings wouldn’t even be present if I didn’t save changes before exit.

I personally would disable Secureboot/TPM and install win10 that won’t require TPM, problem solved. Optionally use rufus and create a new usb stick for win11 to install it without TPM.

Never forget your free Anaconda after you landet on Hutton Orbital :stuck_out_tongue_winking_eye:

o7 cmrd :boom: :rocket:

There is several topics around the web on how to bypass windows 11 requirements

disable windows%2011 tpm requirement - sx.nix.dk