PC will no longer boot after following interrupted upgrade/update instructions

I followed the instructions on this page per suggestion from support, to recover from an interrupted update:

Now my computer won’t boot at all.
It instead opens up a Dell Inspirion 3880 (hardware) screen and shows a boot sequence starting with Manjaro.
The choices are RESTORE SETTINGS or EXIT.
I am afraid to choose RESTORE SETTINGS (??) I have no idea what that will do.

If I choose EXIT, the computer just turns off.
What a nightmare.

Can anyone tell me what is happening? I can’t even boot from USB anymore.

This suggests a hardware problem. It could be that your CMOS battery has died.

This is a fairly new computer. Anyway this just started after I booted from USB, dropped to a prompt and entered these commands, and then rebooted.
I know it has to have something to do with the problem:

[ -f /var/lib/pacman/db.lck ] && rm -f /var/lib/pacman/db.lck
pacman-mirrors -f
pacman -Syyu

Wouldn’t a dying CMOS battery at least stop working occasionally first?
I mean it never had a problem at all until this morning after this update.

If you understand what those commands do, then you would know that what you’re saying is impossible.

Your computer doesn’t recognize any boot devices, which is a UEFI issue. None of the commands in that tutorial come even close to touching the UEFI settings.

No, all the CMOS battery does is make sure that your onboard clock keeps the correct time even when the machine is powered down and disconnected from the power grid, and to keep your UEFI settings stored in NVRAM. If the battery dies, then you will only notice that when the system boots.

What are the odds of the battery dying or a hardware failure at the exact same moment as this interrupted system update/crash though?
I mean you have to admit it that is far fetched.

Coincidences do happen. It may be freaky that they happen like this, but it’s not impossible.

If this is not a laptop, try checking if the drives are all still properly connected, and whether the memory modules are properly seated.

This computer is only a year or so old.
Anyway now its running “Dell SupportAssist OS Recovery”. It started all by itself.


X Error: NO_BOOT

Its now proceeding to do a Startup Repair. I have a Windows and Manjaro partitions, it looks like the Windows partition has taken over.
It says Partition Table X An issue was detected with a red X.

I guess I can only hope Windows will recover the boot sector without deleting my Linux files. I don’t know what else to do I can’t boot at all anymore.

What a nightmare.
Before I ran those commands I could at least access my files on the bootable USB. I wish I had backed up the system then. But the instructions just said to reboot.
How could I possibly have anticipated

Well, that is important information that you should have mentioned right away. :thinking:

I don’t think it will wipe your Manjaro installation, but it will probably override the boot loader and mess up the UEFI boot settings.

Let it do its thing for now, and when it’s finished, try booting up and see whether you can still boot into Manjaro. If not, then you’ll have to boot up from the USB stick and reinstall GRUB from within a chroot environment, like so… :arrow_down:

sudo -i
manjaro-chroot -a
grub-install --recheck

Thats what I keep trying to do, boot from the bootable Manjaro USB again.
It won’t do it. It keeps bringing up the Dell lnspirion screen.
Now if I boot the computer without hitting any key at all, it says


I don’t really need the Windows partition anymore, I haven’t gone in there in a year. I just need the Linux side. Its the OS that came preloaded on the PC. In fact I’d like to just delete it. I only partitioned in case I’d need Windows for something.
If I type “ls”, I see what look like filesystems
It looks like this was a boot issue. The computer looks to be working fine, but it won’t boot the USB or Manjaro.

Is there a way to recover this from the grub> prompt?

That indicates that GRUB was installed, but not configured.

Yes, GRUB has a very minimal built-in shell. It should have a help command, which will give you a list of possible commands while in the GRUB shell.

Grub was configured, but it appears to have been deleted or removed by the update this morning or the commands I typed.

Is there any way I can back up my files to a USB hard drive now, off the GRUB prompt? Before anything else happens
I have an external USB hard drive right here.

Then again that might be a mistake, I’d have to overwrite the backup I have now, which is old but then I’d lose that too if it writes corrupted.

That is possible, yes. The GRUB runtime configuration is normally stored in the files /boot/grub/grub.cfg and /boot/grub/grubenv, but the user configuration is generally done via /etc/default/grub and bash scripts under /etc/grub.d/. The update-grub script should normally reinstall the user configuration into the /boot/grub/grub.cfg file.

No, the GRUB shell is very minimal and only recognizes the filesystem of the partition the GRUB files are on. You cannot mount anything with it.

Try rebooting your computer with the Manjaro USB plugged in and enter the UEFI settings before it starts booting. Then in there, enter the boot settings and (re-)assign the USB device. Hopefully it will then rescan the bus and find the bootable USB stick. I had to do this myself to get my UEFI to recognize the Ventoy-prepared stick, and once the UEFI recognized the device, it was added to the UEFI boot menu options.

Once you can boot off of the USB stick, you should be able to properly reinstall GRUB with all of its original configuration — if necessary, you can try downloading GRUB again from the repo while in the chroot environment, in which case it should come with a working configuration — or even reinstall Manjaro if you think that would be easiest.

When I hit F12 when booting, I get the boot selection menu.
If I choose USB, it says “No bootable devices found.” Even though the USB drive flashes like its being read.

If I put the USB drive in another computer, the bootable Manjaro is there.
It worked once earlier.
Why won’t it boot off the USB?

Google says this and its tempting,

How can I repair the grub boot loader while on the bootable Manjaro filesystem?

These are the steps that worked for me, without having to install any new packages:

Boot into Manjaro installer.
Open terminal.
sudo manjaro-chroot -a (and select system to mount)
grub-install /dev/sda (it's sda for me; make sure you choose the right drive!)
grub-install --recheck /dev/sda.


I’m not howling btw, Google highlighted it lol.


Have you done anything on the Windows end in the meantime, like updating Windows? This is known to mess up the UEFI boot settings.

Either way, you must not hit F12 at boot, but whatever the hotkey is for entering your UEFI settings, and the USB stick must be plugged in already. On many motherboards, the hotkey is Del, but it could be another key on yours.

Once you are in the UEFI settings, look for the boot devices settings. The bootable devices should each be listed there, in a specific order. It is there that you must assign one of those devices to the USB stick. This should prompt the UEFI to rescan the USB bus and find the Ventoy boot loader.

And for future reference… :arrow_down:


These two can be combined into a single command, by the way… :arrow_down:

grub-install --recheck /dev/sda

I’m assuming /dev/sda is your root filesystem?
How do you ‘make sure you choose the right drive’?