Pc "stuck" after last major update

hello to everybody :slight_smile:
had a bit of issues with most of my machines with the last major update, but with the 2 laptops are mostly over or minor. I was away when I did the updates on those, came back and updated my wife’s desktop pc and as usual if something most go fully wrong it’s not with the machine(s) I use…
Now the pc does boot, but there’s no communication to the monitor, it’s dead, just as if I switch it on but the pc is still off, same with the hdmi connected TV.
If I boot with a live nothing on the monitor, but the TV will work… and after a couple of minutes the monitor starts working too.
This is what I get if I run inxi -Fza:

  Kernel: 5.15.2-2-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
  parameters: BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=it tz=UTC
  misobasedir=manjaro misolabel=MANJARO_XFCE_212PRE1 quiet
  systemd.show_status=1 apparmor=1 security=apparmor driver=free
  nouveau.modeset=1 i915.modeset=1 radeon.modeset=1
  Desktop: Xfce 4.16.0 tk: Gtk 3.24.29 info: xfce4-panel wm: xfwm 4.16.1
  vt: 7 dm: LightDM 1.30.0 Distro: Manjaro Linux base: Arch Linux
  Type: Desktop Mobo: ASUSTeK model: PRIME H310-PLUS R2.0 v: Rev X.0x
  serial: <filter> UEFI: American Megatrends v: 1605 date: 07/14/2020
  Info: Quad Core model: Intel Core i3-9100F bits: 64 type: MCP
  arch: Kaby Lake note: check family: 6 model-id: 9E (158) stepping: A (10)
  microcode: EA cache: L2: 6 MiB
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3
  bogomips: 28808
  Speed: 800 MHz min/max: 800/4200 MHz Core speeds (MHz): 1: 800 2: 800
  3: 800 4: 800
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX unsupported
  Type: l1tf mitigation: PTE Inversion
  Type: mds mitigation: Clear CPU buffers; SMT disabled
  Type: meltdown mitigation: PTI
  Type: spec_store_bypass
  mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
  mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional,
  IBRS_FW, STIBP: disabled, RSB filling
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
  Device-1: NVIDIA GK208B [GeForce GT 710] vendor: ZOTAC driver: nouveau
  v: kernel bus-ID: 01:00.0 chip-ID: 10de:128b class-ID: 0300
  Display: x11 server: X.Org compositor: xfwm4 v: 4.16.1 driver:
  loaded: modesetting alternate: fbdev,vesa display-ID: :0.0 screens: 1
  Screen-1: 0 s-res: 1280x1024 s-dpi: 96 s-size: 339x271mm (13.3x10.7")
  s-diag: 434mm (17.1")
  Monitor-1: HDMI-1 res: 1280x1024 hz: 60 dpi: 47
  size: 698x392mm (27.5x15.4") diag: 801mm (31.5")
  Monitor-2: VGA-1 res: 1280x1024 dpi: 80 size: 408x255mm (16.1x10.0")
  diag: 481mm (18.9")
  OpenGL: renderer: NV106 v: 4.3 Mesa 21.2.5 direct render: Yes
  Device-1: Intel 200 Series PCH HD Audio vendor: ASUSTeK
  driver: snd_hda_intel v: kernel bus-ID: 00:1f.3 chip-ID: 8086:a2f0
  class-ID: 0403
  Device-2: NVIDIA GK208 HDMI/DP Audio vendor: ZOTAC driver: snd_hda_intel
  v: kernel bus-ID: 01:00.1 chip-ID: 10de:0e0f class-ID: 0403
  Sound Server-1: ALSA v: k5.15.2-2-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.19 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.40 running: no
  Device-1: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel bus-ID: 05:00.0
  chip-ID: 8086:2723 class-ID: 0280
  IF: wlp5s0 state: up mac: <filter>
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
  vendor: ASUSTeK PRIME B450M-A driver: r8169 v: kernel port: d000
  bus-ID: 06:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp6s0 state: down mac: <filter>
  Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8
  bus-ID: 1-9:5 chip-ID: 8087:0029 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 1 state: down bt-service: enabled,running
  rfk-block: hardware: no software: yes address: see --recommends
  Local Storage: total: 133.57 GiB used: 0 KiB (0.0%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 model: 128GB PCS 2.5 SSD size: 119.24 GiB
  block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s type: SSD
  serial: <filter> rev: 0A0 scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 type: USB vendor: SanDisk model: Cruzer Blade
  size: 14.33 GiB block-size: physical: 512 B logical: 512 B type: N/A
  serial: <filter> rev: 1.00 scheme: MBR
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
  Message: No partition data found.
  Alert: No swap data was found.
  System Temperatures: cpu: 29.8 C mobo: 27.8 C gpu: nouveau temp: 43.0 C
  Fan Speeds (RPM): N/A
  Processes: 222 Uptime: 9m wakeups: 0 Memory: 31.3 GiB
  used: 1.88 GiB (6.0%) Init: systemd v: 249 tool: systemctl Compilers:
  gcc: N/A Packages: pacman: 1136 lib: 311 flatpak: 0 Shell: Bash v: 5.1.8
  running-in: xfce4-terminal inxi: 3.3.08

Kernel on the pc is 5.13 something that could be part of the problem maybe?
How can I sort this? I realize there are somewhat similar threads in the forum, but I’ve got quite confused by what I’ve read so far, and haven’t been able to do much :frowning:
I guess I should manjaro-chroot -a then possibly install a more updated kernel? And? Or? Thanks a lot!


Not according to inxi provided

but i guess you provided this from live media …
Moving on, it seems you have

so, this should help

1 Like

thanks, yes, 5.15 from the live media, I’ll have a look at your link asap (i.e. tomorrow) and I’ll be back, I guess :smiley:

sorry if I disappeared!
Just tried to follow the instructions you linked, I’ve first manjaro-chrooted -a then as the links:

sudo mhwd -r pci video-nvidia

and this worked all right. Then:

sudo mhwd -i pci video-nvidia-470xx

but it failed:

error: target not found: linux513-nvidia-470xx
Error: pacman failed!
Error: script failed!

Not sure why and what should I do… looking in the forum and wiki, but if some helps come it will be appreciated :slight_smile:

And happy holidays, New Year, Christmas or whatever :smiley:

I’ve tried this:

inxi -G
12Graphics:  12Device-1 NVIDIA GK208B [GeForce GT 710] 12driver nouveau 12v kernel
           12Display 12server X.Org 12driver 12loaded nvidia 12resolution 121 1280x1024~60Hz
           122 1280x1024
           12OpenGL 12renderer NV106 12v 4.3 Mesa 21.2.5

and then:

sudo mhwd -a pci nonfree 0300

but got the same reply :frowning:

error: target not found: linux513-nvidia-470xx
Error: pacman failed!
Error: script failed!

You need to update your kernel to linux 5.15 as 5.13 with modules is no longer in the repos.

1 Like

if I try to do that I get this error message (after having chrooted -a):

[manjaro /]#  sudo mhwd-kernel -i linux515
Error: You can't reinstall your current kernel. Please use 'pacman -Syu' instead to update.

I guess because the live has linux 515?
Should I then install a different kernel on the live then?

If you boot the system to a live ISO you will need to mount your system - chroot - then install the linux515 kernel and modules.

this is what I’ve done:

[manjaro manjaro]# manjaro-chroot -a
grub-probe: error: cannot find a GRUB drive for /dev/sdb1.  Check your device.map.
grub-probe: error: cannot find a GRUB drive for /dev/sdb1.  Check your device.map.
==> Mounting (ManjaroLinux) [/dev/sda2]
 --> mount: [/mnt]
 --> mount: [/mnt/boot/efi]
[manjaro /]# sudo mhwd-kernel -i linux515
Error: You can't reinstall your current kernel. Please use 'pacman -Syu' instead to update.

What’s wrong? Thanks and sorry bothering you today :slight_smile:

mhwd-kernel will operate on the running system - not the chrooted

You need to install it manually in chroot

sudo pacmann -Syu linux515 linux515-nvidia-YYYxx
1 Like


ok, it worked and now I can boot again on that machine.
Actually there seem to be still at least one minor issue (after booting and logging in most of the screen is black except for a band on the right side and the bottom, after moving a bit the mouse, or the wheel… not sure yet, the full desktop is shown…) but I’ll work on that later.
Again, many thanks to you and to bogdancovaciu :smiley:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.