Pc says Failed to start simple desktop display manager

I was installing chromium and it said:
chromium: error while loading shred libraries: libicui18n.so.69

So I updated libicu to 69 and rebooted my pc

When I rebooted I see: [FAILED] Failed to start Simple Desktop Display Manager.
I am able to use tty2
And now I can’t use my pc, please help!

Did you just do a partial update?
That won’t work - always update all packages at the same time:

$ sudo pacman -Syu

@freggel.doe just beat me to it. :stuck_out_tongue_winking_eye:

Keep in mind partial upgrades are not supported and will cause breakages just like you encountered. See: System Maintenance - Manjaro


I wrote sudo pacman -Syu but it says failed to get file multilib.db

Sounds like you have mirrors that are out of sync and/or your database is out of date or corrupt. This will use the 5 of the fastest mirrors and force a sync:

sudo pacman-mirrors -f5 && sudo pacman -Syyu

Please post full outputs of commands you’re running that generate errors.

1 Like

When I run sudo pacman-mirrors -f5 it lists a list of countries.
When I run sudo pacman -Syyu it says could not sync all databases

Please help us help you by posting the full output as I asked.

This may be helpful for posting output from the TTY:

1 Like

Oh ok, so when I start it says it failed to start sddm. When I run startplasma-x11 it says error while loading shared libraries libicui18n.so.68 cannot open chared object file no such file or directory.

Perhaps you’re not realizing it, but

$ sudo pacman -Syu

not working is actually worse than your initial problem.
Please post the exact error message this command produced, like you were asked before.

1 Like

Idk what I did different but when I run it now it says
error: failed to commit transaction (conflicting files)
plasma-workspace: /usr/share/locale/ta/LC_MESSAGES/kcm_autostart.mo
exists in filesystem (owned by plasma-desktop-primex)
snapd: /snap already exists
errors occurred, no packages were upgraded.

Ok, if the /snap directory has contents, move it out of they way for the time being, else remove it.
Updating should be possible after that:

$ sudo mv /snap /snap.we-will-deal-with-this-later
$ sudo pacman -Syu --overwrite '/usr/share/locale/ta/LC_MESSAGES/kcm_autostart.mo'

If updating worked, then you can restore the previous /snap directory (if it had contents):

$ sudo rmdir /snap && sudo mv /snap.we-will-deal-with-this-later /snap

This worked, thank you so much!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.