Pc freezing with fullscreen programs

Hello, newbie here!
I’ve recently installed a couple of Steam games with Vulkan, and i noticed that after a couple of minutes of playtime fullscreen games tend to completely freeze the computer.
It seems to happen only when i set them on fullscreen, i tried with Call of Duty: World at War just now and my computer even rebooted right after freezing!

From a quick read on the log files i noticed a couple of errors related to the kernel, but im not sure what could cause those errors, nor what do they mean.
Does anyone know what could cause this problem? is there a way to fix it?

Here’s the output of inxi -Fxzc0:

           Kernel: 5.9.11-3-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
           Desktop: KDE Plasma 5.20.4 Distro: Manjaro Linux 
Machine:   Type: Desktop System: Alienware product: Alienware Area-51 R2 v: N/A serial: <filter> 
           Mobo: Alienware model: 0XJKKD v: A00 serial: <filter> UEFI: Alienware v: A14 
           date: 07/02/2018 
CPU:       Info: 6-Core model: Intel Core i7-5930K bits: 64 type: MT MCP arch: Haswell rev: 2 
           L2 cache: 15.0 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 83821 
           Speed: 1791 MHz min/max: 1200/3900 MHz Core speeds (MHz): 1: 1791 2: 1780 3: 3680 
           4: 3448 5: 1536 6: 1319 7: 3670 8: 3113 9: 2460 10: 1634 11: 2195 12: 1246 
Graphics:  Device-1: NVIDIA GM206 [GeForce GTX 960] driver: nvidia v: 455.45.01 bus ID: 02:00.0 
           Device-2: NVIDIA GM206 [GeForce GTX 960] driver: nvidia v: 455.45.01 bus ID: 03:00.0 
           Display: x11 server: X.Org 1.20.10 driver: nvidia resolution: 1920x1080~60Hz 
           OpenGL: renderer: GeForce GTX 960/PCIe/SSE2 v: 4.6.0 NVIDIA 455.45.01 
           direct render: Yes 
Audio:     Device-1: Intel C610/X99 series HD Audio vendor: Dell driver: snd_hda_intel v: kernel 
           bus ID: 00:1b.0 
           Device-2: NVIDIA GM206 High Definition Audio driver: snd_hda_intel v: kernel 
           bus ID: 02:00.1 
           Device-3: NVIDIA GM206 High Definition Audio driver: snd_hda_intel v: kernel 
           bus ID: 03:00.1 
           Device-4: Trust USB microphone Trust USB microphone type: USB 
           driver: hid-generic,snd-usb-audio,usbhid bus ID: 2-1:2 
           Sound Server: ALSA v: k5.9.11-3-MANJARO 
Network:   Device-1: Intel Wireless 7260 driver: iwlwifi v: kernel port: d000 bus ID: 04:00.0 
           IF: wlp4s0 state: down mac: <filter> 
           Device-2: Qualcomm Atheros Killer E220x Gigabit Ethernet vendor: Dell driver: alx 
           v: kernel port: c000 bus ID: 05:00.0 
           IF: enp5s0 state: up speed: 100 Mbps duplex: full mac: <filter> 
Drives:    Local Storage: total: 2.05 TiB used: 1.24 TiB (60.6%) 
           ID-1: /dev/sda vendor: Samsung model: SSD 860 EVO 250GB size: 232.89 GiB 
           ID-2: /dev/sdb vendor: Toshiba model: DT01ACA200 size: 1.82 TiB 
RAID:      Hardware-1: Intel SATA Controller [RAID mode] driver: ahci v: 3.0 bus ID: 00:1f.2 
Partition: ID-1: / size: 211.12 GiB used: 121.64 GiB (57.6%) fs: ext4 dev: /dev/sda2 
Swap:      ID-1: swap-1 type: partition size: 17.08 GiB used: 0 KiB (0.0%) dev: /dev/sda3 
Sensors:   System Temperatures: cpu: 44.0 C mobo: N/A gpu: nvidia temp: 40 C 
           Fan Speeds (RPM): N/A gpu: nvidia fan: 30% 
Info:      Processes: 385 Uptime: 29m Memory: 15.53 GiB used: 3.50 GiB (22.5%) Init: systemd 
           Compilers: gcc: 10.2.0 Packages: 1537 Client: KDE Plasma v: 5.20.4 inxi: 3.1.08  `

Here’s the output of journalctl related to the crash:

Thanks in advance! ^^

UPDATE: i tried changing the kernel to the latest LTS version of linux (should be 5.4) but the problem still remains, it also freezed a couple of times while using Opera and while looking at the BIOS too! Could it be an hardware related problem?