Pc freeze when using youtube on firefox

Hello i’m currently experiencing a problem with my manjaro installation (and with the english language so sorry in advance for my possible mistakes). While using firefox on youtube or when looking at some video streams (on discord for example), the pc start to freeze and become unresponsive. it’s all explained in this post (manjaro-freezes-sometimes-if-youtube-is-used-firefox/57961) but it has been closed since (hence why i’m making a new post).
From what i’ve seen (like armaet, the previous poster, i can’t replicate the problem well enough to provide useful information), it seems to happen randomly when video decoding.
Fearing a hardware issue, i tried the following :

  • 5 consecutive memetestx86 (nothing shown and no error found)
  • s.m.a.r.t test (it’s an old sdd but it is in good health)
  • stress test (by stress, all of the available test always with 4 threads at least 3 time each)
  • blender benchmark (in order to stress my APU)
    but to no avail.
    Something i’ve found curious is that the problem didn’t happened either on windows (i tried other test there in order to be sure and some occt related stress test)
    or on any live usb i’ve tested (either ubuntu, lubuntu, manjaro i3 or manjaro sway).
    All of them kept on during 3-4 days, while doing the harchest video decoding test i know : 1 youtube video at 1080p + 2 gameblog"dot"fr videos at 4k (this site has honestly one of the worst video player i know, even my beefy gaming computer has problems handling these videos)

i’m kinda new to this forum (the old “lurker first time poster”) so i hope i’ve followed the rules
thanks in advance

here is my inxi output :

  Kernel: 5.15.65-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
    root=UUID=b459569f-9fdf-42ea-bfe1-e019aa921cde rw quiet apparmor=1
    security=apparmor udev.log_priority=3
  Desktop: sway v: 1.7 info: waybar vt: 2 dm: greetd Distro: Manjaro Linux
    base: Arch Linux
  Type: Desktop System: LENOVO product: 10J0S2CH00 v: ThinkCentre M700
    serial: <superuser required> Chassis: type: 3 serial: <superuser required>
  Mobo: LENOVO model: 30D2 v: SDK0J40697 WIN 3305028826571
    serial: <superuser required> UEFI: LENOVO v: FWKTBFA date: 06/23/2022
  ID-1: hidpp_battery_0 charge: 62% condition: N/A volts: 3.9 min: N/A
    model: Logitech G903 LIGHTSPEED Wireless Gaming Mouse w/ HERO type: N/A
    serial: <filter> status: discharging
  RAM: total: 7.65 GiB used: 3.41 GiB (44.6%)
  RAM Report: missing: Required tool dmidecode not installed. Check
  Info: model: Intel Core i3-6100T bits: 64 type: MT MCP arch: Skylake-S
    gen: core 6 level: v3 built: 2015 process: Intel 14nm family: 6
    model-id: 0x5E (94) stepping: 3 microcode: 0xF0
  Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
    L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
    L3: 3 MiB desc: 1x3 MiB
  Speed (MHz): avg: 1736 high: 2361 min/max: 800/3200 scaling:
    driver: intel_pstate governor: powersave cores: 1: 900 2: 1747 3: 1936
    4: 2361 bogomips: 25610
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat
    arch_capabilities arch_perfmon art avx avx2 bmi1 bmi2 bts clflush
    clflushopt cmov constant_tsc cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64
    dtherm dts epb ept ept_ad erms est f16c flexpriority flush_l1d fma fpu
    fsgsbase fxsr ht hwp hwp_act_window hwp_epp hwp_notify ibpb ibrs ida
    intel_pt invpcid invpcid_single lahf_lm lm mca mce md_clear mmx monitor
    movbe mpx msr mtrr nonstop_tsc nopl nx pae pat pbe pcid pclmulqdq pdcm
    pdpe1gb pebs pge pln pni popcnt pse pse36 pti pts rdrand rdseed rdtscp
    rep_good sdbg sep smap smep ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp
    syscall tm tm2 tpr_shadow tsc tsc_adjust tsc_deadline_timer vme vmx vnmi
    vpid x2apic xgetbv1 xsave xsavec xsaveopt xsaves xtopology xtpr
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data mitigation: Clear CPU buffers; SMT vulnerable
  Type: retbleed mitigation: IBRS
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl and seccomp
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: IBRS, IBPB: conditional, RSB filling,
    PBRSB-eIBRS: Not affected
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
  Device-1: Intel HD Graphics 530 vendor: Lenovo driver: i915 v: kernel
    arch: Gen-9 process: Intel 14n built: 2015-16 ports: active: DP-2,DP-3
    empty: DP-1, HDMI-A-1, HDMI-A-2, HDMI-A-3 bus-ID: 00:02.0
    chip-ID: 8086:1912 class-ID: 0300
  Display: wayland server: Xwayland v: 22.1.3 compositor: sway v: 1.7
    driver: gpu: i915 d-rect: 4000x1440 display-ID: 1
  Monitor-1: DP-2 pos: right model: Samsung C27JG5x serial: <filter>
    built: 2019 res: 2560x1440 hz: 144 dpi: 109 gamma: 1.2 scale: 1
    size: 597x336mm (23.5x13.23") diag: 685mm (27") ratio: 16:9 modes:
    max: 2560x1440 min: 720x400
  Monitor-2: DP-3 pos: primary,left model: Samsung SMB1940W serial: <filter>
    built: 2011 res: 1440x900 hz: 75 dpi: 90 gamma: 1.2 scale: 1.10000002384186
    size: 408x255mm (16.06x10.04") diag: 481mm (18.9") ratio: 16:10 modes:
    max: 1440x900 min: 720x400
  Message: Wayland GBM/EGL data currently not available.
  Device-1: Intel 100 Series/C230 Series Family HD Audio vendor: Lenovo
    driver: snd_hda_intel v: kernel bus-ID: 00:1f.3 chip-ID: 8086:a170
    class-ID: 0403
  Sound Server-1: ALSA v: k5.15.65-1-MANJARO running: yes
  Sound Server-2: sndio v: N/A running: no
  Sound Server-3: JACK v: 1.9.21 running: no
  Sound Server-4: PulseAudio v: 16.1 running: no
  Sound Server-5: PipeWire v: 0.3.57 running: yes
  Device-1: Intel Ethernet I219-V vendor: Lenovo driver: e1000e v: kernel
    port: N/A bus-ID: 00:1f.6 chip-ID: 8086:15b8 class-ID: 0200
  IF: eno1 state: down mac: <filter>
  Device-2: Guillemot RTL8188S WLAN Adapter type: USB driver: r8712u
    bus-ID: 1-2:2 chip-ID: 06f8:e034 class-ID: 0000 serial: <filter>
  IF: wlp0s20f0u2 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: dynamic noprefixroute scope: global
  IP v6: <filter> type: noprefixroute scope: link
  WAN IP: <filter>
  Message: No bluetooth data found.
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 238.47 GiB used: 39.88 GiB (16.7%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Samsung model: MZNLN256HCHP-00000
    size: 238.47 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 100Q scheme: GPT
  Message: No optical or floppy data found.
  ID-1: / raw-size: 80 GiB size: 78.19 GiB (97.73%) used: 11.69 GiB (15.0%)
    fs: ext4 dev: /dev/sda2 maj-min: 8:2 label: N/A
    uuid: b459569f-9fdf-42ea-bfe1-e019aa921cde
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 312 KiB
    (0.1%) fs: vfat dev: /dev/sda1 maj-min: 8:1 label: NO_LABEL
    uuid: 175A-EB3B
  ID-3: /home raw-size: 158.17 GiB size: 154.63 GiB (97.76%) used: 28.19 GiB
    (18.2%) fs: ext4 dev: /dev/sda3 maj-min: 8:3 label: N/A
    uuid: ccf1931c-e593-4e58-9840-46a7ac511362
  Alert: No swap data was found.
  Message: No unmounted partitions found.
  Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 12 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 1-2:2 info: Guillemot RTL8188S WLAN Adapter type: Network
    driver: r8712u interfaces: 1 rev: 2.0 speed: 480 Mb/s power: 500mA
    chip-ID: 06f8:e034 class-ID: 0000 serial: <filter>
  Hub-2: 1-6:3 info: Alcor Micro Hub ports: 4 rev: 1.1 speed: 12 Mb/s
    power: 100mA chip-ID: 058f:9254 class-ID: 0900
  Hub-3: 1-6.1:4 info: VIA Labs USB2.0 Hub ports: 4 rev: 2.1 speed: 12 Mb/s
    chip-ID: 2109:2815 class-ID: 0900
  Device-1: 1-6.1.2:6 info: Griffin PowerMate type: HID driver: powermate
    interfaces: 1 rev: 1.0 speed: 1.5 Mb/s power: 100mA chip-ID: 077d:0410
    class-ID: 0300
  Device-2: 1-6.1.3:7 info: Logitech Cordless Mouse Receiver
    type: Keyboard,Mouse,HID driver: logitech-djreceiver,usbhid interfaces: 3
    rev: 2.0 speed: 12 Mb/s power: 98mA chip-ID: 046d:c539 class-ID: 0300
  Device-3: 1-6.1.4:8 info: Apple Aluminium Keyboard (ANSI)
    type: Keyboard,Mouse driver: apple,usbhid interfaces: 2 rev: 2.0
    speed: 12 Mb/s power: 250mA chip-ID: 05ac:024f class-ID: 0301
  Device-4: 1-6.3:5 info: Uni Class 2Port KVMSwitcher type: HID
    driver: hid-generic,usbhid interfaces: 2 rev: 1.1 speed: 1.5 Mb/s
    power: 96mA chip-ID: 10d5:55a2 class-ID: 0300 serial: <filter>
  Hub-4: 2-0:1 info: Super-speed hub ports: 6 rev: 3.0 speed: 5 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  System Temperatures: cpu: 51.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 193 Uptime: 5m wakeups: 2 Init: systemd v: 251 default: graphical
  tool: systemctl Compilers: gcc: 12.2.0 clang: 14.0.6 Packages: pm: pacman
  pkgs: 1041 libs: 288 tools: pamac,yay pm: flatpak pkgs: 0 Shell: Zsh v: 5.9
  running-in: foot inxi: 3.3.21

Is the same if you run it from terminal with:

If that works better with no freeze, check this Firefox - ArchWiki to make it permanent.

thanks a lot i will try from there (i’ll get back to you in a week)

hello, as i said i’m coming back to you. It seems that i stil have that problem.
While looking at firefox configuration, i saw that firefox is already configured to work with wayland (i’ve looked the provided link in order to be sure) even when not using the MOZ_ENABLE_WAYLAND flag.