Paste not working on my application Signal (Signal Desktop)

I’ve noticed I’ve got a problem in signal-desktop. I can’t paste the text string I’m trying to get there. I’ve tried ctrl+v (nothing happens) and right-click to trigger the contextual menu and hopefully a paste option, but those options (copy and paste) are not listed.

Is it just me? If it is, what can I do to get those functions working properly? If it’s not, what information should I share to help as an user (mostly uninformed in the mystical arts of Linux)?

the sequence is:
highlight it → CTRL-C
go where you want it and right click there
then CTRL-v to paste it

under Xorg it is usually enough to highlight some text
and then go to where you want it and middle click to paste it

Some clipboard managing helpers might interfere.

In wayland it may be somewhat different.

Thank you for the input, but it’s not relevant. I’m copying in another application. What I’m trying to do is to paste, not select text inside Signal to copy it and paste elsewhere.

… well, if you are sure … :man_shrugging:

you want to paste $something from $somewhere into Signal?

I’ve tried from various applications. The copy there is ok, I can copy it, the text string is in the clipboard, I can paste it, cross paste between the applications - but not to Signal.

you can copy from everywhere
you can’t paste to signal
while you can do the same to everywhere else?

I don’t know the answer - but having cleared this up may help others help you.

How did you install Signal and is this on X11 or Wayland?

Hello @mithrial, thank you for your time.

echo $XDG_SESSION_TYPE  ✔ wayland

Does that answer your question?
I can’t remember what was the setup used for the last time I installed it. It’s been too long for my goldfish attention span. I know I ran it both on Wayland or on X11 at some point.

Additionally : the problem is solved after a reboot. The contextual menu from right-click shows all the normal options again. It will go back to that state needing a reboot to work properly, I suspect, since it has happened again today (= options not listed anymore).

I’m having trouble phrasing my description correctly. I’ll try to do better :

My startup point in this report is wanting to paste a text string already in the clipboard, copied from another application, to a Signal chat thread.

In all the other applications (Firefox and libre office writer) I tried to use the copy-paste mechanic worked.

In Signal,

  1. the contextual menu from right click is almost empty. I should have made a print screen. I’ll do it next time it happens.
  2. Trying to use the keyboard shortcut ctrl+v doesn’t work. Just plain nothing happens.

The end result is : I can’t paste content to Signal.

I didn’t try to copy from Signal when the application is in that state to paste it elsewhere. I could try it next time.

Hello! here’s a print-screen of the right-click menu. As you may notice, the paste option is not listed.

The text string IS in the clipboard.

I also successfully tried to copy from Signal to paste it elsewhere. After having done that, I tried to paste in Signal again, from Firefox, and the paste option had reappeared.

It seems that for some reason, Signal is not always informed or able to detect the content of the clipboard.

Try logging into an X11 session and see if the issue persists.

Have you tried middle click pasting? Highlight something and paste the text with middle click.

We need to know if you can copy and paste within Signal or when pasting something you copied outside of Signal only, including middle click paste.