Password required to use partition

Hi, everyone

skippable self-introduction xD
I’m new to manjaro, and to Linux in general. Just installed it on this crappy office laptop, since I coudn’t resolve the grub issue that was only affecting PopOS, and I didn’t really like Mint cos it didn’t support some of the software I like. I have Zorin on an old WinXP PC, and had PopOS on my main PC before that drive died.

Anyway, back to the point. Partition I’m using for personal files requires me to enter admin password every time I want to access it, copy/paste files etc. I don’t understand why (it’s not encrypted).

My idea was to upgrade my acc to root. I don’t see any way of upgrading my acc status in the setting like I had on Zorin. It only offers me to create another acc, which I don’t really like the idea of.

Also, is it even wise to upgrade myself to root, or is there another way to resolve this issue with the partition? This slows me down too much.

screenshot (just add dot before com, since it appears forum doesn’t allow embeds not links)–> tinyurlcom/image3312

This usually happens happens if you mount it through the GUI.
If you mount it with correct permisions through fstab and make sure your user is the owner, you shouldn’t have these issues.
What filesystem is on the drive? ext4, xfs, ntfs?

No. It is not wise.
Your user account is part of the wheel group, which means it’s part of the admin user group. That should be sufficient enough for all the tasks you need to do.


Hi, thanks for replying

It’s ext4, was that a mistake? Should (and can I) reformat it?

Would it be too much to ask how does one do that?

If you reuse a partition from another Linux system or you have created on from scratch you need to ensure the correct permissions.

The best approach to mounting disk devices is to use systemd


This is true.
However, there’s a nooby shortcut. I always used gnome-disks to set my disk mounts up.
gnome-disks is a friendly gui…

You can navigate to /mnt/ yourself and create a folder that you want to use. I made T3, then figured out how to make it belong to me and allow all permissions for me.

Then go to gnome-disks and sort out your disk (here’s my 3TB Tosh).

This kills 2 birds with one stone - it writes lines in your fstab.
This line appeared after I used gnome-disks:
LABEL=T3 /mnt/T3 auto nosuid,nodev,nofail,x-gvfs-show,noauto 0 0

I’m no expert, I’m not very clever - and one simple error or oversight in fstab can render your system bricked, so I liked gnome-disks.

When you start your system, systemd reads this file and creates mounts…

Once you’ve sorted the disk out and got it working over a reboot, then you should look to enhance the process with a systemd mount (search this forum).

I found the temporary systemd created file and used it as a basis for creating a permanent systemd entry.

So first thing to do is to make your /mnt folder (anywhere you like, I just like /mnt) and make it yours so you can read/write in there.

1 Like

If you use the same user name inside your other Linux systems then most simple way would be to mount the data partiton as follows below your /home/$USER folder in all your /etc/fstab files.

First, create the folder (certainly could be named differently or located slightly differently, but below /home/$USER)::

sudo mkdir /home/$USER/Data

So, in the above example I have selected a new sub-folder named Data.

Then create the /etc/fstab file entry (in this example ext4 file system has been assumed):

UUID={UUID of the partition} /home/{your user name}/Data ext4 defaults,noatime 0 2

Obviously, the UUID and your user name habe to be adjusted, accordingly. :wink:

This works for me flawless in a multi-boot environment.

1 Like

Solved it. I’m so stupid :sweat_smile:
Permissions tab options in properties were usually greyed out everytime I tried to give myself ownership there. What didn’t cross my mind before is to go into properties AFTER typing the password and getting access to the partition.
I did that now and switched ownership from root to my username.

Thank you all for replying. :bowing_man:
This must be the nicest forum I’ve seen so far. :slightly_smiling_face:

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.