Passwd Absurd problem

I am trying to install a program and I cannot in any way enter the password in my system, but this problem appears if I try to install a program or if I look for super user permissions, it is as if the terminal no longer recognizes my password .
I even tried to change the password with passwd and I succeeded, not even the new one is accepted, I don’t understand what happens, what can this absurd thing depend on? In case you ask me if some key does not work it is not possible, as I have even copied the password in a document and pasted it on the terminal. I have never had a similar problem before I have no idea what else to do.

pacdiff -o

And nothing, the problem was solved as soon as I wrote the post, I really don’t know what happened to my OS, it happened while I was trying to install this program to work well with cuda.

sudo pamac install cudnn

I gave the command anyway, but by the way, what is it for?

Its for checking if you have any pacnews or similar. What was the output?

pacdiff -o

I think yes, but i don’t know what is this

That means its nothing to do with your OP … but you should still manage those properly…

[not that long ago a PAM update created pacnew files that needed to be merged … otherwise passwords would be broken … it was possible, but not the case here]

That is, does that string of code that results from the command mean it has nothing to do with my operating system? I mean do I have to worry about safety?

Read the link … you have to deal with pacnew files whenever you get them.
It does have to do with your system. Whether or not it has much to do with ‘safety’ depends on the file.
I just meant it wasnt related to your initial ‘problem’ that you say ‘solved itself’.

I honestly did not understand, could you explain yourself better? Maybe let’s start from something simple, since I noticed that my password did not work, there is a real security risk of the system, from what can I understand whether or not there has been an access to the system not allowed?
I’m reading the link you sent me in the meantime.

I couldn’t figure out how a file that contains the saved packages for installed packages could change my password, or prevent me from using it. And in any case, something is not right, something like this has never really happened to me.

Don’t worry if you don’t have the answer, I solved it by changing the password, so I’m in an iron barrel :wink:

I dont have an answer because there is basically no information to go off of.
the pacnew was not related.
I have no idea if you were mistyping the password or it was some other misconfiguration, or what.
But I very highly doubt that ‘your system was hacked’ or anything similar.

The password certainly had to be typed well as in addition to having repeated it 27 times I also copied it into a document which I then used to change the password, to be exact to write the old one and then use the new one. So if it wasn’t correct I doubt it could have changed it. In any case, I also think that the system has not been hacked, but this experience made me realize how important security is and I think that inquiring about it can only help.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.