Partitions suddenly disappear in Thunar (File manager)

I have Manjaro Xfce on my laptop.
There are 4 partitions on my hard drive: sda1, sda2, sda3, and sda4. (please see the screenshot from Gparted where they are shown). Sda3 is a swap partition. Sda2 is where a previous version of Manjaro is located but currently it’s not used (I just use it to find older files I may need). Sda1 is NTFS formatted and empty right now. The current Manjaro is installed on sda4.

Until today, when I would opet File Manager (Thunar), I would always see the two other partitions displayed on the left side-bar, under “Devices”. Their size was also always shown in Gigabytes.

However, as of today (and for no apparent reason), I see a completely different thing under Devices. I see only “File system” and “Filesystem root”. So there is no way to select and easily mount the other partitions just by clicking them in Thunar.

I know that there is an old DVD drive in my laptop which is kind of broken and failing at the moment, so perhaps it managed to confuse Thunar somehow… I am not sure. Today I only tried to install Stellarium via Pamac but even after I removed it, Thunar still doesn’t display the other partitions correctly.

Those other partitions are still present and can be accessed, but they are not visible in Thunar’s left side-bar.

I encountered the same situation briefly about a month ago when I used Double Commander, it seemed to confuse Thunar and disable displaying of partitions, but that strange behavior stopped when I would restart the system and not use Double Commander.

Does anyone know what might have happened here and how to fix it?

I forgot to upload the screenshots


and I just noticed that this is also shown under Thunar’s preferences:

You know what package to install back, then.

1 Like

Actually I don’t. :slight_smile:

As far as I can see in Pamac, those packages seem to be already installed. What should I do?

Try this:

This is how your fstab might look:
# /etc/fstab: static file system information.
# Use 'blkid' to print the universally unique identifier for a device; this may
# be used with UUID= as a more robust way to name devices that works even if
# disks are added and removed. See fstab(5).
# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=ed58f94b-8baf-4074-8cfb-a20f14b571b9 /              ext4    defaults,noatime,x-gvfs-show 0 1
UUID=318051e3-f93a-4cff-8090-f0fb5ab64bab swap           swap    defaults,noatime,x-gvf-show 0 0

Back to the basics then.

Ok, here is my computer’s info:

inxi --admin --verbosity=7 --filter --width
  Kernel: 5.13.19-2-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.13-x86_64
  root=UUID=19e5159c-5319-487e-ad14-8a7a0f90db33 rw
  Desktop: Xfce 4.16.0 tk: Gtk 3.24.29 info: xfce4-panel wm: xfwm 4.16.1 vt: 7
  dm: LightDM 1.30.0 Distro: Manjaro Linux base: Arch Linux
  Type: Portable System: Dell product: Inspiron 3521 v: A05
  serial: <superuser required> Chassis: type: 8 v: A05
  serial: <superuser required>
  Mobo: Dell model: 06X37M v: A00 serial: <superuser required>
  UEFI-[Legacy]: Dell v: A05 date: 01/03/2013
  ID-1: BAT1 charge: N/A condition: N/A volts: 0.5 min: 11.1
  model: Simplo DELL 4DMNG31N type: Unknown serial: <filter> status: Unknown
  RAM: total: 3.71 GiB used: 1.69 GiB (45.4%)
  RAM Report: permissions: Unable to run dmidecode. Root privileges required.
  Info: Dual Core model: Intel Core i5-3337U bits: 64 type: MT MCP
  arch: Ivy Bridge family: 6 model-id: 3A (58) stepping: 9 microcode: 21
  cache: L1: 128 KiB L2: 512 KiB L3: 3 MiB bogomips: 14368
  Speed: 809 MHz min/max: 800/2700 MHz Core speeds (MHz): 1: 835 2: 1873
  3: 1299 4: 991
  Flags: acpi aes aperfmperf apic arat arch_perfmon avx bts clflush cmov
  constant_tsc cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts epb ept
  erms est f16c flexpriority flush_l1d fpu fsgsbase fxsr ht ibpb ibrs ida
  lahf_lm lm mca mce md_clear mmx monitor msr mtrr nonstop_tsc nopl nx pae pat
  pbe pcid pclmulqdq pdcm pebs pge pln pni popcnt pse pse36 pti pts rdrand
  rdtscp rep_good sep smep ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp syscall
  tm tm2 tpr_shadow tsc tsc_deadline_timer vme vmx vnmi vpid x2apic xsave
  xsaveopt xtopology xtpr
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: spec_store_bypass
  mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
  mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional,
  IBRS_FW, STIBP: conditional, RSB filling
  Type: srbds status: Vulnerable: No microcode
  Type: tsx_async_abort status: Not affected
  Device-1: Intel 3rd Gen Core processor Graphics vendor: Dell driver: i915
  v: kernel bus-ID: 00:02.0 chip-ID: 8086:0166 class-ID: 0300
  Device-2: AMD Mars [Radeon HD 8730M] vendor: Dell driver: radeon v: kernel
  alternate: amdgpu bus-ID: 01:00.0 chip-ID: 1002:6601 class-ID: 0300
  Device-3: Suyin Laptop_Integrated_Webcam_HD type: USB driver: uvcvideo
  bus-ID: 1-1.4:5 chip-ID: 064e:812e class-ID: 0e02
  Display: x11 server: X.Org compositor: xfwm4 v: 4.16.1 driver:
  loaded: ati,modesetting,radeon alternate: fbdev,vesa display-ID: :0.0
  screens: 1
  Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.2x8.0")
  s-diag: 414mm (16.3")
  Monitor-1: LVDS-1 res: 1366x768 hz: 60 dpi: 101 size: 344x194mm (13.5x7.6")
  diag: 395mm (15.5")
  OpenGL: renderer: Mesa DRI Intel HD Graphics 4000 (IVB GT2)
  v: 4.2 Mesa 21.2.5 compat-v: 3.0 direct render: Yes
  Device-1: Intel 7 Series/C216 Family High Definition Audio vendor: Dell
  driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:1e20
  class-ID: 0403
  Sound Server-1: ALSA v: k5.13.19-2-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.19 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.40 running: yes
  Device-1: Realtek RTL810xE PCI Express Fast Ethernet vendor: Dell
  driver: r8169 v: kernel port: 2000 bus-ID: 07:00.0 chip-ID: 10ec:8136
  class-ID: 0200
  IF: enp7s0 state: down mac: <filter>
  Device-2: Broadcom BCM43142 802.11b/g/n
  vendor: Dell Wireless 1704 802.11n + BT 4.0 driver: wl v: kernel
  modules: bcma bus-ID: 08:00.0 chip-ID: 14e4:4365 class-ID: 0280
  IF: wlp8s0 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
  broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  IF-ID-1: tun0 state: unknown speed: 10 Mbps duplex: full mac: N/A
  IP v4: <filter> scope: global
  IP v6: <filter> scope: global
  IP v6: <filter> virtual: stable-privacy scope: link
  WAN IP: <filter>
  Device-1: Broadcom BCM43142 Bluetooth 4.0 type: USB driver: btusb v: 0.8
  bus-ID: 1-1.1:3 chip-ID: 0a5c:21d7 class-ID: fe01 serial: <filter>
  Report: rfkill ID: hci0 rfk-id: 1 state: down bt-service: enabled,running
  rfk-block: hardware: no software: yes address: see --recommends
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 931.51 GiB used: 190.25 GiB (20.4%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/sda maj-min: 8:0 vendor: Seagate model: ST1000LM024 HN-M101MBB
  size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 3.0 Gb/s
  type: HDD rpm: 5400 serial: <filter> rev: 0004 scheme: MBR
  Optical-1: /dev/sr0 vendor: HL-DT-ST model: DVD+-RW GU70N rev: A103
  dev-links: cdrom
  Features: speed: 24 multisession: yes audio: yes dvd: yes
  rw: cd-r,cd-rw,dvd-r,dvd-ram state: running
  ID-1: / raw-size: 328.7 GiB size: 322.47 GiB (98.11%)
  used: 74.48 GiB (23.1%) fs: ext4 dev: /dev/sda4 maj-min: 8:4 label: N/A
  uuid: 19e5159c-5319-487e-ad14-8a7a0f90db33
  ID-2: /run/media/blueflame5/5E2F5B7A23A21796 raw-size: 236.6 GiB
  size: 236.6 GiB (100.00%) used: 71.8 MiB (0.0%) fs: ntfs dev: /dev/sda1
  maj-min: 8:1 label: N/A uuid: 5E2F5B7A23A21796
  ID-3: /run/media/blueflame5/928e4281-91d4-4d4b-a729-614fd5144f7a
  raw-size: 341.8 GiB size: 335.37 GiB (98.12%) used: 115.7 GiB (34.5%)
  fs: ext4 dev: /dev/sda2 maj-min: 8:2 label: N/A
  uuid: 928e4281-91d4-4d4b-a729-614fd5144f7a
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 24.41 GiB used: 0 KiB (0.0%) priority: -2
  dev: /dev/sda3 maj-min: 8:3 label: N/A
  uuid: 688948e9-2ee4-432c-80aa-18ea6b3cad8b
  Message: No unmounted partitions found.
  Hub-1: 1-0:1 info: Full speed or root hub ports: 2 rev: 2.0 speed: 480 Mb/s
  chip-ID: 1d6b:0002 class-ID: 0900
  Hub-2: 1-1:2 info: Intel Integrated Rate Matching Hub ports: 6 rev: 2.0
  speed: 480 Mb/s chip-ID: 8087:0024 class-ID: 0900
  Device-1: 1-1.1:3 info: Broadcom BCM43142 Bluetooth 4.0 type: Bluetooth
  driver: btusb interfaces: 4 rev: 2.0 speed: 12 Mb/s chip-ID: 0a5c:21d7
  class-ID: fe01 serial: <filter>
  Device-2: 1-1.3:4 info: Realtek RTS5129 Card Reader Controller
  type: <vendor specific> driver: rtsx_usb,rtsx_usb_ms,rtsx_usb_sdmmc
  interfaces: 1 rev: 2.0 speed: 480 Mb/s power: 500mA chip-ID: 0bda:0129
  class-ID: ff00 serial: <filter>
  Device-3: 1-1.4:5 info: Suyin Laptop_Integrated_Webcam_HD type: Video
  driver: uvcvideo interfaces: 2 rev: 2.0 speed: 480 Mb/s power: 500mA
  chip-ID: 064e:812e class-ID: 0e02
  Hub-3: 2-0:1 info: Full speed or root hub ports: 2 rev: 2.0 speed: 480 Mb/s
  chip-ID: 1d6b:0002 class-ID: 0900
  Hub-4: 2-1:2 info: Intel Integrated Rate Matching Hub ports: 6 rev: 2.0
  speed: 480 Mb/s chip-ID: 8087:0024 class-ID: 0900
  Hub-5: 3-0:1 info: Hi-speed hub with single TT ports: 4 rev: 2.0
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Hub-6: 4-0:1 info: Super-speed hub ports: 4 rev: 3.0 speed: 5 Gb/s
  chip-ID: 1d6b:0003 class-ID: 0900
  System Temperatures: cpu: 51.0 C mobo: N/A gpu: radeon temp: 43.0 C
  Fan Speeds (RPM): cpu: 2500
  Processes: 251 Uptime: 8m wakeups: 1 Init: systemd v: 249 tool: systemctl
  Compilers: gcc: 11.1.0 clang: 13.0.0 Packages: 1491 pacman: 1479 lib: 385
  flatpak: 5 snap: 7 Shell: Bash v: 5.1.8 running-in: xfce4-terminal
  inxi: 3.3.09

By the way, I tried to re-install the gvfs package in terminal even though it appeared to be already installed. I typed this:

sudo pacman -S gvfs

and after restarting my laptop, now Thunar again displays the partitions in its left side-bar as it always had in the past. However, when I go to the Thunar root and look at the Advanced options, the warning about the missing gvfs package is still there.

So it seems that this computer is still having some problems and things are still quite flaky… each and every system booting is different and some unknown factor can mess things up seemingly randomly (but doesn’t always). Could the failing DVD drive be the culprit?

5.13 is eol. Switch to a newer and stable kernel:

Also update your bios

Don’t blame the DVD now :point_up_2: :stuck_out_tongue_winking_eye:

1 Like

You could try to update your BIOS/UEFI. The update is marked “Urgent” and dated Nov. 2018:

Unfortunately, I am unable to update the BIOS because it can only be updated from the Windows environment and I don’t have Win on this laptop (one of the really stupid decisions by Dell to support BIOS update only on Win).

Furthermore, even if I installed Windows, it would still not allow me to update BIOS because the battery on this laptop is not working, and the BIOS update utility from Dell doesn’t want to proceed in that case.

I can try with a more recent kernel, actually it’s already installed and I used it for some time, but it seems to be much more memory demanding than the one I am using now (my laptop has only 4 Gb RAM), so I keep returning to this older kernel as it is so much faster.

Rather than using a kernel which is not supported anymore you can use other older kernel like 5.10 lts and 5.4 lts

What I noticed on my Thunar is this, open thunar as normal user then access the other drive/fs/whatever then open thunar as root and they should show up as they didn’t on mine until I as suggested.