Partitioning error when installing Manjaro GNOME on Windows laptop

So I am currently trying to get Manjaro GNOME installed on my HP Pavilion x360 laptop. However, I keep running into errors when using Calamares. Originally, I was trying to install a different Arch distro called XeroLinux. I first burned it to my usb with rufus and succeeded in booting into it. On install I would get an error that it could not delete/resize/create a partition (I tried installing along-side, erasing disk, and replacing partition). After switching to Ventoy, searching around for a few days on the internet, and trying for hours to figure out what was wrong, I came up with nothing. At that point, I decided to switch to trying to install Manjaro GNOME (now I like it more) because it had a much larger community if I needed help. So, I tried the same things, and same errors. I booted using Ventoy and then Rufus but no difference. I even tried using gparted to manually change the partitions, but it would not touch my root Windows drive (it’s not locked). I tried deleting space on my windows drive and dual-booting, no luck. I searched more on the forums and internet but couldn’t find a solution. I’m guessing there is some setting possibly in my BIOS or Windows that I need to change but I have no idea, I’m new to linux in general. I’ll leave some specs for some more info:

Windows drive size: ~240gb
USB size: ~16gb

Running “inxi -Fza”:

  Kernel: 5.13.19-2-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
  parameters: BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=us tz=UTC
  misobasedir=manjaro misolabel=MANJARO_GNOME_2116 quiet
  systemd.show_status=1 driver=free nouveau.modeset=1 i915.modeset=1
  Desktop: GNOME 40.5 tk: GTK 3.24.30 wm: gnome-shell dm: GDM 40.1
  Distro: Manjaro Linux base: Arch Linux
  Type: Convertible System: HP
  product: HP Pavilion x360 Convertible 14m-dh1xxx v: Type1ProductConfigId
  serial: <filter> Chassis: type: 31 serial: <filter>
  Mobo: HP model: 866E v: 90.07 serial: <filter> UEFI: Insyde v: F.04
  date: 08/30/2019
  ID-1: BAT0 charge: 30.0 Wh (100.0%) condition: 30.0/30.0 Wh (100.0%)
  volts: 12.9 min: 11.6 model: 333-54-5D-A HT03041XL type: Li-ion
  serial: <filter> status: Full
  Device-1: hid-0018:04F3:2A47.0004-battery model: ELAN2514:00 04F3:2A47
  serial: N/A charge: N/A status: N/A
  Info: Quad Core model: Intel Core i5-10210U bits: 64 type: MT MCP
  arch: Kaby Lake note: check family: 6 model-id: 8E (142) stepping: C (12)
  microcode: EA cache: L2: 6 MiB
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  bogomips: 33615
  Speed: 600 MHz min/max: 400/4200 MHz Core speeds (MHz): 1: 600 2: 1364
  3: 960 4: 839 5: 619 6: 639 7: 700 8: 700
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
  mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
  mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
  Type: srbds mitigation: TSX disabled
  Type: tsx_async_abort status: Not affected
  Device-1: Intel CometLake-U GT2 [UHD Graphics] vendor: Hewlett-Packard
  driver: i915 v: kernel bus-ID: 00:02.0 chip-ID: 8086:9b41 class-ID: 0300
  Device-2: Cheng Uei Precision Industry (Foxlink) HP Wide Vision HD Camera
  type: USB driver: uvcvideo bus-ID: 1-4:3 chip-ID: 05c8:03d3 class-ID: 0e02
  Display: wayland server: 1.20.13 compositor: gnome-shell driver:
  loaded: i915 note: n/a (using device driver) - try sudo/root display-ID: 0
  resolution: <missing: xdpyinfo>
  OpenGL: renderer: Mesa Intel UHD Graphics (CML GT2) v: 4.6 Mesa 21.2.3
  direct render: Yes
  Device-1: Intel Comet Lake PCH-LP cAVS vendor: Hewlett-Packard
  driver: snd_hda_intel v: kernel
  alternate: snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 00:1f.3
  chip-ID: 8086:02c8 class-ID: 0403
  Sound Server-1: ALSA v: k5.13.19-2-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.19 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.38 running: no
  Device-1: Realtek Realtek Bluetooth 4.2 Adapter type: USB driver: btusb
  v: 0.8 bus-ID: 1-10:5 chip-ID: 0bda:b00a class-ID: e001 serial: <filter>
  Report: rfkill ID: hci0 rfk-id: 2 state: up address: see --recommends

Error message after installation by resizing Windows drive to leave space for Manjaro:

The installer failed to resize partition /dev/nvme0n1p3 on disk 'INTEL HBRPEKNX0101AH'.

Shrink partition ‘/dev/nvme0n1p3’ from 237.23 GiB to 178.35 GiB
Job: Check file system on partition ‘/dev/nvme0n1p3’
Checking partition ‘/dev/nvme0n1p3’ before resize/move failed.

Thanks for the help.

You need to disable fast boot. Check your windows drive in Windows with

chkdsk C:

You may also want to use Windows’ own partition management tool to resize an NTFS partition.

1 Like

check about adding module vmd for Nvme disks

1 Like
  • Fast startup disabled in Control Panel > Power Options > Choose what power off button does.
  • Disk check output:
The type of the file system is NTFS.
Volume label is Windows.

WARNING!  /F parameter not specified.
Running CHKDSK in read-only mode.

Stage 1: Examining basic file system structure ...
  1199872 file records processed.
File verification completed.
 Phase duration (File record verification): 17.95 seconds.
  15813 large file records processed.
 Phase duration (Orphan file record recovery): 9.67 milliseconds.
  0 bad file records processed.
 Phase duration (Bad file record checking): 0.52 milliseconds.

Stage 2: Examining file name linkage ...
  2336 reparse records processed.
  1460230 index entries processed.
Index verification completed.
 Phase duration (Index verification): 45.38 seconds.
  0 unindexed files scanned.
 Phase duration (Orphan reconnection): 6.00 seconds.
  0 unindexed files recovered to lost and found.
 Phase duration (Orphan recovery to lost and found): 5.48 milliseconds.
  2336 reparse records processed.
 Phase duration (Reparse point and Object ID verification): 15.70 milliseconds.

Stage 3: Examining security descriptors ...
Security descriptor verification completed.
 Phase duration (Security descriptor verification): 121.53 milliseconds.
  130180 data files processed.
 Phase duration (Data attribute verification): 1.47 milliseconds.
CHKDSK is verifying Usn Journal...
  40441888 USN bytes processed.
Usn Journal verification completed.
 Phase duration (USN journal verification): 264.34 milliseconds.

Windows has scanned the file system and found no problems.
No further action is required.

 234884508 KB total disk space.
 162891900 KB in 613188 files.
    358800 KB in 130181 indexes.
         0 KB in bad sectors.
   1322204 KB in use by the system.
     65536 KB occupied by the log file.
  70311604 KB available on disk.

      4096 bytes in each allocation unit.
  58721127 total allocation units on disk.
  17577901 allocation units available on disk.
Total duration: 1.16 minutes (69772 ms).
  • I also tried to run a check with a fix. It did not work on 3rd party software (MiniTool Partition Wizard) but did with chkdsk c: /f in cmd. Both checks did have to be done on startup
  • I tried resizing c: in Window’s native partition manager. I got 13gigs free in the partition now but I couldn’t get enough.
  • I tried running gparted as a live iso. It had trouble recognizing anything. All I saw was “ataraid” as the only volume. Searching it turned up nothing other than “ATA software RAID support”

So, I definitely screwed something up ._.

I don’t think you screwed something up. The native Windows partition manager won’t move any files that are open. The Gparted live ISO probably doesn’t have drivers for your hard drive controller. Now that you’ve disabled fast startup, you should be fine to resize the Windows partition using Gparted from the Manjaro GNOME iso.

Gparted still doesn’t work on Manjaro ._.
I can’t resize it or do anything to dev/nvme0n1, my c: drive.
It also displays the disk type as ataraid


Looks like your laptop has Intel RST, or?

So check if the correct module has been loaded:

lsmod | grep vmd

if there is no output, then vmd is not loaded.

Check also at your BIOS/UEFI Settings if AHCI mode is enabled (not RAID) and if possible Intel RST is disabled.

Yes, I just checked and it does have Intel RST.
The command returns no output, so I guess it isn’t loaded.
I was not able to find AHCI in my BIOS/UEFI (I also found an HP forum post that told me it was not in BIOS) . I couldn’t find RST either, I could only find the driver version in the built in Intel app.

@dgd ok…

Please check if the ISO is at least version 21.1.4. There should be the vmd module included by default.

Only thingI could suggest then (since there is no documentation of the UEFI): Make photos of the screen on every menu page of the UEFI and post them here… I can’t believe there is no option for that, and if not, then I mark HP once again on my blacklist…

However… since fakeRaid is enabled by default and you cannot change it, you will have to deal with dmraid…

Question: Do you have 2 drives, which are merged together as raid? The inxi output is cut off at this part…

1 Like

ISO is good: manjaro-gnome-21.1.6-211017-linux513.iso
I can’t post images so I’ll link them:
ibb co/album/X7Qk9Y
That should be all of the relevant screens. Also note: On the startup settings page, I did select option 8.
I don’t have 2 drives, I just have the drive that came with the laptop and the USB stick. As for the merging, I honestly don’t really know much about it so I can’t say.

By all meaning it is not a UEFI or a BIOS. That is the Windows Recovery Menu. You have to quickly press F10 after pressing the power button to enter the UEFI Settings. Look here: User Guide

Or maybe this option should do it:

My bad.
ibb co/album/G3wbgG

I’m not seeing the option to configure it.

Are you able to boot into Windows and use HP’s own tools to upgrade the BIOS and Intel RST firmware?

It appears the most recent one for your model is Insyde F.11 released in September 2021 (you’re currently on F.4, 2019)

Be careful though, as HP’s own website and software updater sometimes doesn’t even know the correct version. :roll_eyes:

Do not try the manual method. If HP’s own update tool cannot upgrade your BIOS or Intel firmware, then don’t worry about it. Leave it as it is.

Ok I updated to F.11 using that method.
Screenshots: ibb co/album/jkmGb1
Since the update reset my settings, I turned safe boot back off and changed the boot order.
Lmk if I need to send more screenshots


So I see there is actually a firmware-raid of 2 drives:

The first one must be the nvme and the second one is the optane cache drive.

So only way to install Linux here is when you

  • disable the optane cache
  • disable raid
  • disable intel RST
  • change to AHCI mode

but I assume windows is installed that way here, so there you need to reinstall windows. That means: You need to wipe the whole disk.

Then you will be able to install Manjaro.

Why that? Because such a raid can not be shrunk and also linux does not support optane cache drives…

Viola! Looks like the latest firmware exposes this option in your BIOS menus. :partying_face:

This is the main issue. @dgd may lose all their data if they cleave the Optane (cache) from the main NVMe storage.

If they decide to use this approach, Manjaro will see two different block devices (even though they are on the same physical device):

  • /dev/nvme0 (240 GB)
  • /dev/nvme1 (13.4 GB)

It does, but not in the “seamless” way that Windows uses it. If the Optane is liberated, it can be used as a distinct 13.4 GB block device (to install the Linux OS? to use as a scratch disk? to use for /tmp or /cache? to use with the bcache method? etc.)

Yeah, agree :wink:

@dgd, so that we understand, are you hoping to dual-boot Windows 10 and Manjaro, or use Manjaro exclusively on the laptop?

If you decide to use Manjaro exclusively, do understand the implications:

  • It might be very difficult (and risky!) to revert to a dual-boot configuration if you later change your mind
  • You lose out on “Windows features” such as flashing the firmware of the chipset and BIOS, etc. (You can still do it without Windows, but it is a hellish adventure! Believe me.)

Thanks @megavolt and @winnie for the feedback. So dual-booting is the slight preference, but from what I’m understanding, it would be a difficult process. I am completely fine running Manjaro exclusively and wiping as long as I can find out how to do it correctly so that it will install and work and I won’t just have a $700 brick.


After trying everything above, I simply had to disable disk optimization from Intel’s Optane software from their app on Windows.
Now I have Manjaro GNOME dual-booted with Windows :wink: