Partition Manager crash

When I try to open KDE Partition Manager, after typing the root password the application closes.
I tried to launch it using a Terminal and the information was this …


Loaded backend plugin: “pmsfdiskbackendplugin”
“Using backend plugin: pmsfdiskbackendplugin (1)”
“Scanning devices…”
“Device found: Samsung SSD 970 EVO Plus 500GB”
getting temp failed for “/dev/nvme0n1” : Success
getting powered on time failed for “/dev/nvme0n1” : Success
getting power cycles failed for “/dev/nvme0n1” : Success
Segmentation fault (core dumped)

Any idea?
Thanks in advance!

Have you tried your $USER password?

1 Like

Did you launch it with sudo infront and using your normal (non-root) password?

1 Like

If I type …

sudo partitionmanager

the GUI doesn’t show up at all and the answer is …

[sudo] password for knight:
QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to ‘/tmp/runtime-root’
QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to ‘/tmp/runtime-root’
“Session bus not found\nTo circumvent this problem try the following command (with Linux and bash)\nexport $(dbus-launch)”

Without sudo, now the answer is …

Loaded backend plugin:  "pmsfdiskbackendplugin"
"Using backend plugin: pmsfdiskbackendplugin (1)"
"Scanning devices..."
smartctl initialization failed for  "/dev/loop0" :  No such file or directory
error during smart output parsing for  "/dev/loop0" :  No such file or directory
"Device found: loop0"
unknown file system type  ""  on  "/dev/loop0"
Segmentation fault (core dumped)

Maybe there’s a problem with the SSD where I have installed the system, Samsung SSD 970 EVO Plus.
I have 5 drives … 1 NVMe SSD, 1 SSD SATA, and 3 HDD SATA.
They all work perfectly.

You shouldn’t start partitionmanager with sudo…

1 Like

I never do it.

I don’t even use that app, i just wanted to rule-out root privileges.
Never thought about it using the XDG_RUNTIME_DIR :blush:
Anyway disregard that reply then :wink:

1 Like

If KDE’s partitionmanager is not working properly, I would recommend to use GParted.

1 Like

Could it be a problem with the firmware of the Samsung SSD 970 EVO Plus?
I don’t think so, because I’ve installed GParted and it works properly.
It seems the problem is with this application only.

If it’s crash you need to obtain backtrace with debug symbols installed. Try running it inside gdb if DrKonqi is not showing backtrace.

1 Like

I understood nothing from your comment.
Install symbols?
Inside gdb? What’s gdb?
DrKonqi? What’s that?
I’m sorry, I thought I knew about Linux but it’s obvious I’m not there yet.