Paperwork application not starting, problem with required jarowinkler python package

I’ve been using this GNOME program called paperwork for a while now to scan and organize various documents. I’ve used it to scan a lot of important documents. Now I can’t access any of them because something has gone wrong with my package management and there’s something missing. the application no longer starts now and the problem may have something to do with some package called jarowinkler. Below is where the terminal output starts to go wrong

[INFO  ] [openpaperwork_core            ] Loading plugin 'paperwork_backend.i18n.pycountry' ...
Error in sys.excepthook:
Traceback (most recent call last):
  File "/usr/lib/python3.10/site-packages/openpaperwork_core/", line 29, in _on_uncaught_exception
  File "/usr/lib/python3.10/site-packages/openpaperwork_core/", line 430, in call_one
    assert \
AssertionError: A plugin has been loaded without being initialized. Call core.init() first

Original exception was:
Traceback (most recent call last):
  File "/usr/lib/python3.10/site-packages/pkg_resources/", line 581, in _build_master
  File "/usr/lib/python3.10/site-packages/pkg_resources/", line 909, in require
    needed = self.resolve(parse_requirements(requirements))
  File "/usr/lib/python3.10/site-packages/pkg_resources/", line 800, in resolve
    raise VersionConflict(dist, req).with_context(dependent_req)
pkg_resources.ContextualVersionConflict: (jarowinkler 1.2.1 (/usr/lib/python3.10/site-packages), Requirement.parse('jarowinkler<2.0.0,>=1.2.2'), {'rapidfuzz'})

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
  File "/usr/bin/paperwork-gtk", line 33, in <module>
    sys.exit(load_entry_point('paperwork==2.1.1', 'gui_scripts', 'paperwork-gtk')())
  File "/usr/lib/python3.10/site-packages/paperwork_gtk/", line 216, in main
  File "/usr/lib/python3.10/site-packages/paperwork_gtk/", line 187, in main_main
    core.call_all("config_load_plugins", "paperwork-gtk", DEFAULT_GUI_PLUGINS)
  File "/usr/lib/python3.10/site-packages/openpaperwork_core/", line 406, in call_all
    callback(*args, **kwargs)
  File "/usr/lib/python3.10/site-packages/openpaperwork_core/config/", line 99, in config_load_plugins
  File "/usr/lib/python3.10/site-packages/openpaperwork_core/", line 406, in call_all
    callback(*args, **kwargs)
  File "/usr/lib/python3.10/site-packages/openpaperwork_core/config/backend/", line 247, in config_backend_load_plugins
  File "/usr/lib/python3.10/site-packages/openpaperwork_core/", line 165, in load
    module = importlib.import_module(module_name)
  File "/usr/lib/python3.10/importlib/", line 126, in import_module
    return _bootstrap._gcd_import(name[level:], package, level)
  File "<frozen importlib._bootstrap>", line 1050, in _gcd_import
  File "<frozen importlib._bootstrap>", line 1027, in _find_and_load
  File "<frozen importlib._bootstrap>", line 1006, in _find_and_load_unlocked
  File "<frozen importlib._bootstrap>", line 688, in _load_unlocked
  File "<frozen importlib._bootstrap_external>", line 883, in exec_module
  File "<frozen importlib._bootstrap>", line 241, in _call_with_frames_removed
  File "/usr/lib/python3.10/site-packages/paperwork_backend/i18n/", line 1, in <module>
    import pycountry
  File "/usr/lib/python3.10/site-packages/pycountry/", line 10, in <module>
    import pkg_resources
  File "/usr/lib/python3.10/site-packages/pkg_resources/", line 3260, in <module>
    def _initialize_master_working_set():
  File "/usr/lib/python3.10/site-packages/pkg_resources/", line 3234, in _call_aside
    f(*args, **kwargs)
  File "/usr/lib/python3.10/site-packages/pkg_resources/", line 3272, in _initialize_master_working_set
    working_set = WorkingSet._build_master()
  File "/usr/lib/python3.10/site-packages/pkg_resources/", line 583, in _build_master
    return cls._build_from_requirements(__requires__)
  File "/usr/lib/python3.10/site-packages/pkg_resources/", line 596, in _build_from_requirements
    dists = ws.resolve(reqs, Environment())
  File "/usr/lib/python3.10/site-packages/pkg_resources/", line 795, in resolve
    raise DistributionNotFound(req, requirers)
pkg_resources.DistributionNotFound: The 'jarowinkler<2.0.0,>=1.2.2' distribution was not found and is required by rapidfuzz

What I’ve tried to fix it so far:

I tried re-installing the program by running sudo pacman -Rns paperwork, then installing again. This did not work.

I’m freaking out a bit here. All of the PDFs are still available to me but the way paperwork organizes the files makes it difficult to figure out what’s what without the program. I’m in the middle of a home sale/purchase and some important documents were saved with that program. I might need them very soon. Someone please help!

paperwork requires python-levenshtein, which requires python-rapidfuzz, which requires python-jarowinkler.

python-jarowinkler is currently at 1.2.1-1 in the stable channel, but 1.2.3-1 in testing.

I hope someone else has a better answer than just waiting for the next big update.

Install python-jarowinkler from testing with this command:

sudo pacman -U
1 Like

Thanks! That worked. Not sure how it got borked in the first place, but glad I can access my documents again.

Simply the package

needs to be pushed to stable too, but being weekend, might not happen just yet.

python-jarowinkler 1.2.3-1 is now available in the stable branch.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.