Panel not showing up after update


Just ran an update recently (hadn’t been home in a few weeks). Everything seemed fine, but I just noticed that the panel doesn’t show anymore. I had it set on smart show/hide, but hovering at the bottom of the screen has no effect. I trying playing with the display/rebooting etc. but not changes. If I try to get to the Panel setting, I get this error message:

GDBus.Error.ServiceUnknown: the name org.xfce.Panel was not provided by any .service files.

Any ideas?

Okay, so turns out that if I start it manually in terminal it’s fine ($> xfce4-panel).

However it won’t start automatically which is an annoyance. So I guess I’ll have a look at how to add commands at startup.

Would still be nice to know why it just stopped working…

I don’t have a solution, but have a few suggestions. Do them one at a time, and logoff/logon if an action was taken. I’m assuming this is an XFCE-only desktop. If none of this helps, what is your monitor setup and graphics hardware.

  1. Look in $HOME/.xsession-errors, journalctl --boot=0, and coredumpctl for potential relevant errors. Maybe some service is terminating.

  2. Clear content of $HOME/.cache.

    • I suppose the correct way to do this :slight_smile: is to logout first, then log in to a tty (ie. tty: alt-f2 & graphical: alt-f7) and clear cache. Probably could get away with just deleting the sessions file.
    • Or, Settings Manager > Session and Startup > Saved Sessions and click Clear Saved Sessions.
  3. Under Settings Manager > Session and Startup > Application Autostart. Review “XFCE-Panel Workaround”

    • If checked, then uncheck it.
    • If it is unchecked, check it.

    Ref: 1, 2. I don’t run it, but it sounds like it could help.

  4. Temporarily turn off panel hiding. Change panel id if not 0. Use either:

    • Settings Manager > Panel > Panel 0 > Automatically hide the panel
    • Or xfconf-query -c xfce4-panel -p /panels/panel-0/autohide-behavior -s 0

    Never: 0, Intelligently: 1, Always: 2

  5. Disable compositor. Use either

    • Settings Manager > Window Manager Tweaks > Compositor
    • Or xfconf-query -c xfwm4 -p /general/use_compositing -s false
  6. When you have the panel running, and the desktop is as you want it to be, go to Settings Manager > Session and Startup > Current Session and click “Save Session”. Now change the setting to smartly Hide the Panel. Ref: 1

Okay weird - so I initially started it up manually using the command line (as above). I then restarted (still no panel), so launched it manually again and just did my things. Then the next time I restarted, it did show up. Haven’t had issues ever since.

(So I didn’t get to try those suggestions stargazer, but thanks for the comments hopefully may be useful of others if they have issues).

My best guess is that some file got wiped out/replace during the update, and perhaps caused the launcher to fail to start. Perhaps launching it manually/using it for a while allowed xfce to recreate whatever file/config was missing, so it now launched succesfully?

Glad it works, but secretively disappointed we don’t know why :slight_smile: You are right something could have gotten updated, or it’s a timing thing. Removing saved sessions seems like a good place to begin. Sometimes toggling an option is enough to set things straight.

I assume there was a reboot in there some place. :slight_smile: I always reboot after an update and then check .xsession-errors and the journal (journalctl -b0 -perr) to make sure there isn’t anything new.

I also like to run find -newermt "1 minute ago" to see what files have changed.

@franckyvee did you check as @stargazer mentioned (point 3.)?

‘Settings → Sessions and Startup’

under ‘Application Autostart’ is ‘XFCE-Panel workaround’ present and selected?