Panel Action Button behaviour

I have a pc and two laptops, all are on XFCE testing branch and as of today that is 2020-09-02.

The power ‘action button’ to the right of the clock behaves differently on each, though they have the same configuration, see screenshot.

On the pc and laptop1 a menu is displayed, although slightly different I get the options I generally use, but on laptop2 when I click it, it logs out immediately, no confirmation and no menu, so on this laptop I have to also ‘make visible’ Suspend and Reboot and Shutdown, and so now have 4 buttons to click.

I must be missing something simple, but on this device I can’t get the power menu to display on just one button. On the other two even though the button is labelled ‘Log Out’ the menu comes up when clicked.

Can anyone point me in the right direction to get the power menu to come up?

PS I can’t upload the screenshot, new user.

On laptop2 right-click on the panel > Panel > Panel Preferences > Items (tab) > double-click on the Action Buttons item > in the new window make sure to enable (check) the Log out… (the three dots are important, as they indicate that a new dialog window is going to open) option and disable the Log out (without dots) option.

You can also disable (uncheck) those options too in laptop2, because they are going to be present in the popup dialog window.

Thank you.

You’ve explained and summed up better than me why the ‘Log Out’ (with 3 dots) button works as it should, and it does as described on 2 devices. The screenshot would have shown I have this action button enabled just as you explain on all 3 devices, except on laptop2 it instantly logs out. If I hover the mouse pointer over it, it shows the 3 dots, so I know its the correct button, but still instantly logs out when clicked.

So I’ve removed this action button completely, then re-added it again, but it still doesn’t show the menu, hover the mouse pointer over shows ‘Log Out’ with 3 dots, when I click it logs out.

If I enable the other ‘Log Out’ without the dots, then I get the 30 second confirmation box come up, as do the other shutdown options, so they are working as expected.

Can I provide any further information to help fix this?

PS Edited to add. There is another ‘Log Out’ (with dots) icon on the main menu, clicking this also logs straight out

If this doesn’t work for you, you can create a new Launcher in the panel and use this command:


To have the same icon displayed for the new launcher, you can select the one called system-log-out (search it in the All Icons category).

Give it a try and see how that goes.

Thanks for the help.

I think now digging deeper into the problem with your help the issue is not just with the ‘button’. I tried running the following command in a terminal


And laptop2 instantly logs out, though running that command in my other two devices I get the full logout/shutdown menu appear.

So I think if I can get that command when run a terminal to bring up the ‘shutdown’ menu instead of instantly logging out, the 'button problem will be fixed too.

Navigate to Settings > Session and Startup (from the Whisker Menu) and under *Logout Settings check (enable) the option *Prompt on logout.

After doing this, check if the custom launcher and/or the default panel item work as expected.

Thank you, Bingo!

That was the culprit, probably my fault when looking at those settings and not fully aware of what I was doing, or disable by mistake with a clumsy mouse click.

Your assistance much appreciated, and I’ve learnt a bit too!

I do have another question now that one is fixed, but I’ll start another thread.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.