Pamac version problem

Hi. I have a laptop with Manjaro KDE and Windows 10 dual booted. And I also have a Manjaro KDE VM (qemu) running inside Manjaro . To my surprise I found that the pamac on the system install was version 10.1.2 but on the VM it is 10.0.6-2. I tried updating both systems, but they are up-to-date. Could you please tell what is going on. (I love the old interface btw)

Maybe the VM’s mirror is out of date?

Try sudo pacman-mirrors -f5 && sudo pacman -Syyu within the VM.

1 Like

I did sudo pacman-mirrors --fasttrack && sudo pacman -Syyu this morning. :confused:

Ah okay.

Well, seems Pamac version was reversed in stable branch recently. So your desktop got it when it was there, but your update on the VM was “too late” to get it.

2 Likes

Can I revert by desktop pamac version? I prefer the the older pamac :sweat_smile:

If you are on stable branch, you can do sudo pacman -Syuu and it should downgrade it.

1 Like

Thanks a lot, sir. :blush:

If you still have the previous version in /var/cache/pacman/pkg, then you could run… :arrow_down:

sudo pacman -U --ignore --needed /var/cache/pacman/pkg/name-of-the-package
2 Likes

Thank you so much. It solved the problem.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.