Pamac upgrade -a stuck waiting for user input but without any notice/warning

Every time I use the command «pamac upgrade -a» it gets stuck waiting for user input without any notice/warning in the middle of the package list.
If [e/s/N] is pressed it completes the package list, shows the «apply?» notice and acts as requested/expected.
I attach here two screen captures as I think is better than copy/paste in this situation.

Look for the ‘n’ in the middle of the sc, in the «systemd-sysvcompat» line.

This is happening since I started to use pamac cli a couple of months ago, before that I was used to pacman cli.

(Please, help me improve my writing; how would you put into words this?)

I’m not sure if I understood you right, but for me this looks like you were asked if you want to (e)dit the PKGBUILD’s of AUR packages, you said (N)o, which is fine as the upgrade proceeds. Looks pretty normal to me.

1 Like

“aplicar transacción” (apply transaction yes or No) No is défaut value – upper char is alway defaut value (as pacman)
here you want exit without make update
you can add “--no-confirm

EDIT: ok now , I understand you, you press well “N”

No, it isn’t.
Look for the message in the former screen capture. It gets stuck at that point waiting user input without any message.
Message got printed after user input as shown in latter screen capture, and that’s why you se that ‘n’ I pressed in the middle of the package list.
(Please, help me improve my writing; how would you put into words this?)

In that case, this seems like something you need to report to the Gitlab Issue tracker for Pamac.

what is terminal application ? same with other ?

It is terminator terminal application. That could be important info to add to the issue I’m posting at the moment to gitlab pamac as Strit requested.

Have you tried any other, to see if it happens there too?

Like the one your DE ships with.

That sounds basic thing to do, my bad.
I’ve updated everything at the moment, so it only reports «nothing to do».
I’ll try that next time.
For now, I’ve reported to the Pamac Issue tracker:

That reminds me a kind of visual glitch I had when redirecting commands output with tee to log output and at same time being able to interact with the prompts in terminal. Some lines/paragraphs were not at the proper place :smiley:

1 Like

Yes, that could be the reason. I have an alias for that command:
alias pam-upgrade=‘pamac upgrade -a 2>&1 | tee -a “/home/$USER/.logs/pamac-upgrade_$(date +%Y-%m-%d_%H-%M-%S).log”’

Don’t think twice then, you’re the error :stuck_out_tongue:

I see it similarly.
I would suggest splitting the update into

pamac update

(without AUR packages)
and after that to perform

pamac update -a

, whereby only the AUR packages should remain …
This is much more transparent in this case.

I you look in the first little screenshot here is where it stopped and he pressed N (//EDIT: most likely pressed ENTER key, with N as default option)

It is same alias and tee redirection for pacman without any issue with user input requests, so… Can you explain?

I just told my story with same issue, when I was using tee, you confirmed you were using tee and it was not output of pamac but the output of tee so you have 99.99% chance to have the bug I explained with tee. Not having the issue in X case is not really relevant here I think (and the issue I had was with pacman so look better next time :stuck_out_tongue:).

//EDIT: your issue is most likely redirecting an interactive terminal program with tee

You can easily confirm that, change your Manjaro branch, and initiate an update with your alias, and then initiate an update with the normal command. Do it if you understand how to do that. Wait for next update if you don’t.

Done. You’re right. It is a tee issue (or alias issue maybe).
Thanks for your help.

That can be solved or not?

Probably, but remember to close your issue on Gitlab. Also pick your preferred post as solution so this thread is marked as solved.

Look for issues like this one, where people give some workaround for some ‘similar’ problem. I think the issue is related to some buffer I don’t remember, I just stopped using tee as it was not giving me the result I wanted out of the box and didn’t want to hack a solution.
Try google with some search like linux "tee" output mixed I found this maybe it explains the issue

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.