Pamac update wants me to choose provider for dbus-units

Hi all,

For the first time after updating pamac, I am asked to choose between dbus-broker-units and dbus-daemon units in the core update.

Here is my system info:

[manupc@manupc-2 ~]$ sudo inxi --admin --verbosity=7 --filter --no-host --width
[sudo] password for manupc: 
System:
  Kernel: 6.1.69-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc available: hpet,acpi_pm
    parameters: BOOT_IMAGE=/boot/vmlinuz-6.1-x86_64
    root=UUID=1adc77d4-359c-4d50-8e77-204cccc1b265 rw quiet apparmor=1
    security=apparmor udev.log_priority=3 ibt=off
  Desktop: Xfce v: 4.18.1 tk: Gtk v: 3.24.36 info: xfce4-panel wm: xfwm
    v: 4.18.0 dm: LightDM v: 1.32.0 Distro: Manjaro Linux base: Arch Linux
Machine:
  Type: Desktop Mobo: Micro-Star model: PRO B660M-E DDR4 (MS-7D46) v: 1.0
    serial: <filter> UEFI: American Megatrends LLC. v: 2.00 date: 12/27/2021
Battery:
  Message: No system battery data found. Is one present?
Memory:
  System RAM: total: 16 GiB available: 15.48 GiB used: 2.05 GiB (13.2%)
  Array-1: capacity: 64 GiB slots: 4 modules: 1 EC: None
    max-module-size: 16 GiB note: est.
  Device-1: Controller0-DIMMA1 type: DDR4 detail: synchronous size: 16 GiB
    speed: 2133 MT/s volts: curr: 1.2 min: 1.2 max: 1.2 width (bits): data: 64
    total: 64 manufacturer: Corsair part-no: CMK16GX4M1D3600C18 serial: N/A
  Device-2: Controller1-DIMMB1 type: no module installed
CPU:
  Info: model: 12th Gen Intel Core i5-12400F socket: U3E1 bits: 64 type: MT MCP
    arch: Alder Lake gen: core 12 level: v3 note: check built: 2021+
    process: Intel 7 (10nm ESF) family: 6 model-id: 0x97 (151) stepping: 2
    microcode: 0x32
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
    L1: 480 KiB desc: d-6x48 KiB; i-6x32 KiB L2: 7.5 MiB desc: 6x1.2 MiB
    L3: 18 MiB desc: 1x18 MiB
  Speed (MHz): avg: 783 high: 800 min/max: 800/5600 base/boost: 2475/4400
    scaling: driver: intel_pstate governor: powersave volts: 0.9 V
    ext-clock: 100 MHz cores: 1: 800 2: 800 3: 800 4: 800 5: 800 6: 800 7: 600
    8: 800 9: 800 10: 800 11: 800 12: 800 bogomips: 59916
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat
    arch_capabilities arch_lbr arch_perfmon art avx avx2 avx_vnni bmi1 bmi2
    bts cat_l2 cdp_l2 clflush clflushopt clwb cmov constant_tsc cpuid
    cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts ept ept_ad erms est f16c
    flexpriority flush_l1d fma fpu fsgsbase fsrm fxsr gfni hfi ht hwp
    hwp_act_window hwp_epp hwp_notify hwp_pkg_req ibpb ibrs ibrs_enhanced ida
    intel_pt invpcid lahf_lm lm mca mce md_clear mmx monitor movbe movdir64b
    movdiri msr mtrr nonstop_tsc nopl nx ospke pae pat pbe pclmulqdq pdcm
    pdpe1gb pebs pge pku pln pni popcnt pse pse36 pts rdpid rdrand rdseed
    rdt_a rdtscp rep_good sdbg sep serialize sha_ni smap smep
    split_lock_detect ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp syscall tm
    tm2 tpr_shadow tsc tsc_adjust tsc_deadline_timer tsc_known_freq umip vaes
    vme vmx vnmi vpclmulqdq vpid waitpkg x2apic xgetbv1 xsave xsavec xsaveopt
    xsaves xtopology xtpr
  Vulnerabilities:
  Type: gather_data_sampling status: Not affected
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed status: Not affected
  Type: spec_rstack_overflow status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
    sanitization
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB
    filling, PBRSB-eIBRS: SW sequence
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: NVIDIA GK208B [GeForce GT 730] vendor: ASUSTeK driver: nvidia
    v: 470.223.02 alternate: nouveau,nvidia_drm non-free: series: 470.xx+
    status: legacy-active (EOL~2024-09-xx) arch: Kepler code: GKxxx
    process: TSMC 28nm built: 2012-2018 pcie: gen: 1 speed: 2.5 GT/s lanes: 4
    link-max: gen: 2 speed: 5 GT/s lanes: 8 bus-ID: 01:00.0 chip-ID: 10de:1287
    class-ID: 0300
  Display: x11 server: X.Org v: 21.1.10 compositor: xfwm v: 4.18.0 driver: X:
    loaded: nvidia gpu: nvidia display-ID: :0.0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 101 s-size: 483x272mm (19.02x10.71")
    s-diag: 554mm (21.82")
  Monitor-1: HDMI-0 res: 1920x1080 hz: 60 dpi: 102
    size: 476x268mm (18.74x10.55") diag: 546mm (21.51") modes: N/A
  API: OpenGL Message: Unable to show GL data. glxinfo is missing.
Audio:
  Device-1: Intel Alder Lake-S HD Audio vendor: Micro-Star MSI
    driver: snd_hda_intel v: kernel alternate: snd_sof_pci_intel_tgl
    bus-ID: 00:1f.3 chip-ID: 8086:7ad0 class-ID: 0403
  Device-2: NVIDIA GK208 HDMI/DP Audio vendor: ASUSTeK driver: snd_hda_intel
    v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 4 link-max: gen: 2
    speed: 5 GT/s lanes: 8 bus-ID: 01:00.1 chip-ID: 10de:0e0f class-ID: 0403
  API: ALSA v: k6.1.69-1-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsactl,alsamixer,amixer
  Server-1: JACK v: 1.9.22 status: off tools: N/A
  Server-2: PipeWire v: 1.0.0 status: n/a (root, process) tools: pw-cli
  Server-3: PulseAudio v: 16.1 status: active (root, process)
    with: pulseaudio-alsa type: plugin tools: pacat,pactl,pavucontrol
Network:
  Device-1: Intel Ethernet I219-V vendor: Micro-Star MSI driver: e1000e
    v: kernel port: N/A bus-ID: 00:1f.6 chip-ID: 8086:1a1d class-ID: 0200
  IF: eno1 state: up speed: 100 Mbps duplex: full mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  WAN IP: <filter>
Bluetooth:
  Message: No bluetooth data found.
Logical:
  Message: No logical block device data found.
RAID:
  Message: No RAID data found.
Drives:
  Local Storage: total: 476.94 GiB used: 200.81 GiB (42.1%)
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Hikvision
    model: HS-SSD-E3000 512G size: 476.94 GiB block-size: physical: 512 B
    logical: 512 B speed: 31.6 Gb/s lanes: 4 tech: SSD serial: <filter>
    fw-rev: SN06738 temp: 41.9 C scheme: GPT
  SMART: yes health: PASSED on: 79d 8h cycles: 1,595
    read-units: 16,211,752 [8.30 TB] written-units: 6,772,382 [3.46 TB]
  Message: No optical or floppy data found.
Partition:
  ID-1: / raw-size: 476.64 GiB size: 468.09 GiB (98.21%)
    used: 200.81 GiB (42.9%) fs: ext4 block-size: 4096 B dev: /dev/nvme0n1p2
    maj-min: 259:2 label: N/A uuid: 1adc77d4-359c-4d50-8e77-204cccc1b265
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 316 KiB (0.1%) fs: vfat block-size: 512 B dev: /dev/nvme0n1p1
    maj-min: 259:1 label: NO_LABEL uuid: 49F1-3C7C
Swap:
  Alert: No swap data was found.
Unmounted:
  Message: No unmounted partitions found.
USB:
  Hub-1: 1-0:1 info: hi-speed hub with single TT ports: 16 rev: 2.0
    speed: 480 Mb/s (57.2 MiB/s) lanes: 1 mode: 2.0 chip-ID: 1d6b:0002
    class-ID: 0900
  Device-1: 1-1:2 info: Logitech Mouse type: mouse driver: hid-generic,usbhid
    interfaces: 1 rev: 2.0 speed: 1.5 Mb/s (183 KiB/s) lanes: 1 mode: 1.0
    power: 100mA chip-ID: 046d:c077 class-ID: 0301
  Hub-2: 1-9:3 info: Genesys Logic Hub ports: 4 rev: 2.0
    speed: 480 Mb/s (57.2 MiB/s) lanes: 1 mode: 2.0 power: 100mA
    chip-ID: 05e3:0608 class-ID: 0900
  Hub-3: 2-0:1 info: super-speed hub ports: 10 rev: 3.1
    speed: 20 Gb/s (2.33 GiB/s) lanes: 2 mode: 3.2 gen-2x2 chip-ID: 1d6b:0003
    class-ID: 0900
Sensors:
  System Temperatures: cpu: 37.0 C mobo: N/A gpu: nvidia temp: 34 C
  Fan Speeds (rpm): N/A
Info:
  Processes: 276 Uptime: 16m wakeups: 0 Init: systemd v: 254 default: graphical
  tool: systemctl Compilers: gcc: 13.2.1 clang: 16.0.6 Packages: pm: pacman
  pkgs: 1348 libs: 400 tools: pamac pm: flatpak pkgs: 0 Shell: Sudo (sudo)
  v: 1.9.15p4 default: Bash v: 5.2.21 running-in: xfce4-terminal inxi: 3.3.31
[manupc@manupc-2 ~]$

This is what happened when I tried to update pamac:

[manupc@manupc-2 ~]$ sudo pamac update
[sudo] password for manupc: 
Preparing...
Synchronizing package databases...
Choose a provider for dbus-units:
1:  dbus-broker-units  35-2       core
2:  dbus-daemon-units  1.14.10-2  core

Enter a number (default=1): 




What are the different types of dbus-units and which should i choose for my system?

Thank you.

Read stable update announcements. All info is in 2nd post.

1 Like

Hi @newbietolinux,

Had you read the update announcements you would have seen:

2 Likes

Hi zbe and Mirdarthos,

My bad. I see now it is dbus-broker, the default.

Thank you both for directing me.

1 Like

I think the chooser for the Pamac UI is broken for the choice. Just clicking choose seems to select the broker though
image

4 Likes

I am also seeing this blank choose window, on KDE Plasma, immediately after clicking Apply to start the update process:

image

Pacman shows the choice correctly in a terminal, though:

image

3 Likes

For Firefox a box popped up and said please choose a dbus provider, but I saw no chooices. It seems fine, just continued updating.

Hi @Edward78,

Considering in the update announcement it said:

I think, to switch as recommended, you just have to install dbus-broker, to make sure it’s installed.

pamac install dbus-broker

If it’s not installed, it should, I think, as you if you want to replace dbus-daemon with it, to which you should answer yes.

Hope this helps!

Some people seemed to have error messages after picking dbus-broker as default, why?
But can I pick dbus-daemon instead since is still supported? And if I do that, will it be asked to swith it in future updates still?
I checked in pamac and I do have a package called dbus installed, dbus-broker it’s not.

Warnings aren’t errors.

Sure you can. And no, you won’t. But you can switch anytime you want.

Ok, thanks! So it’s pretty safe to do the switch? Should I expect some issues?

Yes. I got that empty screen too. I cancel’d the update and restarted it, and strangely then the menu did show up with the dbus-broker-unit preselected.

Had the updater been able to mark which option is the new default, it would have been even easier :slight_smile:

I faced an issue, when I choosed to install dbus-broker:

Wasn’t a problem for me in the CLI, so can’t give you more advice. But I see there are other people also experiencing problems with the GUI, so rest assured you’re at least not the only one.

1 Like

For now I selected dbus-daemon-units (since is still supported) and updated with no issues!

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.