Pamac update says... remove: pamac-common 10.0.6-2 (Conflicts With libpamac)

Hi, I’m using pamac to update, but getting following message…

Transaction Summary
To remove: pamac-common 10.0.6-2 (Conflicts With libpamac)

not sure if it is ok to click Apply to continue, I tried to google for answer but couldn’t find an exact match, I think it is ok to continue, but don’t want to risk breaking my system.

any advice would be appreciated

Open a terminal and update using pacman

sudo pacman -Syu

Follow the prompts …


thanks for quick reply, I ran the command and was prompted with a warning/error, here is the terminal output…

[hugh@DELL-INSP-MANJARO ~]$ sudo pacman -Syu
[sudo] password for hugh: 
:: Synchronising package databases...
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
:: Starting full system upgrade...
:: Replace pamac-common with extra/libpamac? [Y/n] y

warning: sndio: local (20180120-1) is newer than community (1.7.0-3)
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: installing pacman (6.0.0-1) breaks dependency 'pacman<5.3' required by package-query

not sure what to do here, but I tried google and found a post on axel-hahn website but can’t enter the url here unfortunately

here is the title of the post…

[Manjaro update - pacman (6.0.0-1) breaks dependency ‘pacman<5.3′ required by package-query ]

the post details are in german…

Der grafische Software-Manager wollte pacman nicht aktualisieren … und wegen jenes Konflikts alle möglichen Pakete auch nicht.

The graphical software manager didn’t want to update pacman … and because of that conflict, neither did any possible packages.

it was suggested to remove yaourt and upgrade pacman

but the error here is slightly different to my situation, can you advise best solution?

Remove package-query and whatever requires it.

Probably yaourt

What I meant with follow the prompts was like - remove conflicting packages - they can be reinstalled after the update sync.

So start with

sudo pacman -R package-query

If you get other dependency errors - add the package to the removal list and when removal succeeds you run the update sync - then when update-sync is successful you reinstall packages - that is - if you need them.

thanks for all your support.

I ran following command as suggested…

$ sudo pacman -R package-query

[hugh@DELL-INSP-MANJARO ~]$ sudo pacman -R package-query
checking dependencies...
error: failed to prepare transaction (could not satisfy dependencies)
:: removing package-query breaks dependency 'package-query>=1.9' required by yaourt

So I removed yaourt then removed package-query followed by…

$ sudo pacman -Syu

updates completed successfuly ! Thanks.

I haven’t used yaourt package before, it must have been included during the original install 4 years ago. so I wonder should I reinstall yaourt now ?

It was dropped from the repos and AUR quite some time ago.

No, it’s no longer possible. Did you not learn anything from this experience?

I am sorry if you thought my question was stupid. but I honestly wasn’t aware yaourt was removed. I only asked the question because I wasn’t sure if yaourt or it’s dependencies might be needed for something else in the system.

I try to learn as much as I can but I’m not as sharp as I used to be (74 years old). I was very hurt by your last remark tbh.

this forum has always been most helpful to me over the last few years, so I thank you all for your support.

Best Regards, Hugh

EDIT: I now realise that if I did reinstall yaourt perhaps it would cause same error at the next update . So on hindsight my question was a bit stupid tbh.

That was not my intent, I apologize. I can be quite blunt and straightforward.

I guess you missed that. :point_up:

Yaourt is deprecated and insecure. It’s not compatible with Pacman 6, either. If you like the functionality it had, install Yay.

Thanks for explaining that, much appreciated.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.